summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2017-11-28 10:22:02 +0200
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-11-28 16:03:23 +0000
commit53c1c5dcc1da6aa36ee9f53c5276739053b85897 (patch)
treea93a20b4ae4857e2533e40b07ebd876d9c23a092 /setup.py
parentffcc65d4f04190551de5c71c6f106cb92f9235ab (diff)
downloadpsycopg2-53c1c5dcc1da6aa36ee9f53c5276739053b85897.tar.gz
Remove redundant hasattr checks
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f010ef5..efcf81d 100644
--- a/setup.py
+++ b/setup.py
@@ -214,8 +214,7 @@ or with the pg_config option in 'setup.cfg'.
# Support unicode paths, if this version of Python provides the
# necessary infrastructure:
- if sys.version_info[0] < 3 \
- and hasattr(sys, 'getfilesystemencoding'):
+ if sys.version_info[0] < 3:
pg_config_path = pg_config_path.encode(
sys.getfilesystemencoding())