summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2017-11-28 11:13:38 +0200
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-11-28 16:06:55 +0000
commitc2d082e896e7bcb81231603404e7d4789e56cf00 (patch)
tree56c7c2b3ff51c17897a9b6e9a3a44e87e74348ae /setup.py
parentea76504cd1f8c32c0eb15d337d5e6b44af1cb301 (diff)
downloadpsycopg2-c2d082e896e7bcb81231603404e7d4789e56cf00.tar.gz
Drop support for EOL Python 3.0-3.3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index efcf81d..264078a 100644
--- a/setup.py
+++ b/setup.py
@@ -78,8 +78,6 @@ Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
-Programming Language :: Python :: 3.2
-Programming Language :: Python :: 3.3
Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
@@ -295,7 +293,7 @@ class psycopg_build_ext(build_ext):
# For Python versions that use MSVC compiler 2008, re-insert the
# manifest into the resulting .pyd file.
- if self.compiler_is_msvc() and sysVer in ((2, 7), (3, 0), (3, 1), (3, 2)):
+ if self.compiler_is_msvc() and sysVer == (2, 7):
platform = get_platform()
# Default to the x86 manifest
manifest = '_psycopg.vc9.x86.manifest'
@@ -619,7 +617,7 @@ setup(name="psycopg2",
download_url=download_url,
license="LGPL with exceptions or ZPL",
platforms=["any"],
- python_requires='>=2.7,!=3.0.*,!=3.1.*',
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
description=readme.split("\n")[0],
long_description="\n".join(readme.split("\n")[2:]).lstrip(),
classifiers=[x for x in classifiers.split("\n") if x],