summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Erickson <jerickso@stickpeople.com>2017-06-08 13:11:57 -0600
committerJason Erickson <jerickso@stickpeople.com>2017-06-08 20:11:02 -0600
commitc837261ac1b25d1a3babdd7ea0b08e24f56f4a93 (patch)
treec5cabd8c1822f71e25c78296126281e35966651c /setup.py
parent7d9ef5f952c342f17393c43f9bff368ccf45b5d9 (diff)
downloadpsycopg2-c837261ac1b25d1a3babdd7ea0b08e24f56f4a93.tar.gz
Remove VC9 runtime dependency
Changed check in setup.py to only use vc9 manifest when built against versions that use the MSVC 2008 compiler. Resolves #541. Note that as of VS 2010, a manifest is no longer needed according to this comment, "...we are no longer deploying the VC dlls as Win32 assemblies. They are regular dlls that can be loaded without a manifest." https://connect.microsoft.com/VisualStudio/feedback/details/522121/crtassem-h-missing
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 09c6f84..99f289f 100644
--- a/setup.py
+++ b/setup.py
@@ -295,7 +295,7 @@ class psycopg_build_ext(build_ext):
# For Python versions that use MSVC compiler 2008, re-insert the
# manifest into the resulting .pyd file.
- if self.compiler_is_msvc() and sysVer not in ((2, 4), (2, 5)):
+ if self.compiler_is_msvc() and sysVer in ((2, 6), (2, 7), (3, 0), (3, 1), (3, 2)):
platform = get_platform()
# Default to the x86 manifest
manifest = '_psycopg.vc9.x86.manifest'