summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.appveyor.yml11
-rw-r--r--.travis.yml2
-rw-r--r--doc/src/install.rst2
-rw-r--r--setup.py6
4 files changed, 4 insertions, 17 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 4f9a40c..46f54df 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -15,7 +15,7 @@ environment:
# http://www.appveyor.com/docs/installed-software#python
# Py 2.7 = VS Ver. 9.0 (VS 2008)
- # Py 3.3, 3.4 = VS Ver. 10.0 (VS 2010)
+ # Py 3.4 = VS Ver. 10.0 (VS 2010)
# Py 3.5, 3.6 = VS Ver. 14.0 (VS 2015)
- PYTHON: C:\Python27-x64
@@ -51,15 +51,6 @@ environment:
PYTHON_ARCH: 32
VS_VER: 10.0
- - PYTHON: C:\Python33-x64
- DISTUTILS_USE_SDK: '1'
- PYTHON_ARCH: 64
- VS_VER: 10.0
-
- - PYTHON: C:\Python33
- PYTHON_ARCH: 32
- VS_VER: 10.0
-
PSYCOPG2_TESTDB: psycopg2_test
PSYCOPG2_TESTDB_USER: postgres
PSYCOPG2_TESTDB_PASSWORD: Password12!
diff --git a/.travis.yml b/.travis.yml
index 6152a4b..e6182a7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,8 +9,6 @@ python:
- 3.6
- 3.5
- 3.4
- - 3.3
- - 3.2
install:
- python setup.py install
diff --git a/doc/src/install.rst b/doc/src/install.rst
index c2c245a..8b6651d 100644
--- a/doc/src/install.rst
+++ b/doc/src/install.rst
@@ -18,7 +18,7 @@ The current `!psycopg2` implementation supports:
NOTE: keep consistent with setup.py and the /features/ page.
- Python version 2.7
-- Python 3 versions from 3.2 to 3.6
+- Python 3 versions from 3.4 to 3.6
- PostgreSQL server versions from 7.4 to 10
- PostgreSQL client library version from 9.1
diff --git a/setup.py b/setup.py
index efcf81d..264078a 100644
--- a/setup.py
+++ b/setup.py
@@ -78,8 +78,6 @@ Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
-Programming Language :: Python :: 3.2
-Programming Language :: Python :: 3.3
Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
@@ -295,7 +293,7 @@ class psycopg_build_ext(build_ext):
# For Python versions that use MSVC compiler 2008, re-insert the
# manifest into the resulting .pyd file.
- if self.compiler_is_msvc() and sysVer in ((2, 7), (3, 0), (3, 1), (3, 2)):
+ if self.compiler_is_msvc() and sysVer == (2, 7):
platform = get_platform()
# Default to the x86 manifest
manifest = '_psycopg.vc9.x86.manifest'
@@ -619,7 +617,7 @@ setup(name="psycopg2",
download_url=download_url,
license="LGPL with exceptions or ZPL",
platforms=["any"],
- python_requires='>=2.7,!=3.0.*,!=3.1.*',
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
description=readme.split("\n")[0],
long_description="\n".join(readme.split("\n")[2:]).lstrip(),
classifiers=[x for x in classifiers.split("\n") if x],