summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in2
-rw-r--r--doc/HACKING43
-rw-r--r--psycopg2.cproj1
3 files changed, 1 insertions, 45 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 58aa51a..1603b1b 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -2,7 +2,7 @@ recursive-include psycopg *.c *.h *.manifest
recursive-include lib *.py
recursive-include tests *.py
recursive-include examples *.py somehackers.jpg whereareyou.jpg
-recursive-include doc README HACKING SUCCESS COPYING.LESSER pep-0249.txt
+recursive-include doc README SUCCESS COPYING.LESSER pep-0249.txt
recursive-include doc/src *.rst *.py *.css Makefile
recursive-include scripts *.py *.sh
include scripts/maketypes.sh scripts/buildtypes.py
diff --git a/doc/HACKING b/doc/HACKING
deleted file mode 100644
index f60474c..0000000
--- a/doc/HACKING
+++ /dev/null
@@ -1,43 +0,0 @@
-General information
-*******************
-
-Some help to people wanting to hack on psycopg. First of all, note that
-*every* function in the psycopg module source code is prefixed by one of the
-following words:
-
- psyco is used for function directly callable from python (i.e., functions
- in the psycopg module itself.) the only notable exception is the
- source code for the module itself, that uses "psyco" even for C-only
- functions.
-
- conn is used for functions related to connection objects.
-
- curs is used for functions related to cursor objects.
-
- typecast is used for typecasters and utility function related to
- typecaster creation and registration.
-
-Pythonic definition of types and functions available from python are defined
-in *_type.c files. Internal functions, callable only from C are located in
-*_int.c files and extensions to the DBAPI can be found in the *_ext.c files.
-
-
-Patches
-*******
-
-If you submit a patch, please send a diff generated with the "-u" switch.
-Also note that I don't like that much cosmetic changes (like renaming
-already existing variables) and I will rewrap the patch to 78 columns
-anyway, so it is much better if you do that beforehand.
-
-
-The type system
-***************
-
-Simple types, like integers and strings, are converted to python base types
-(the conversion functions are in typecast_base.c). Complex types are
-converted to ad-hoc types, defined in the typeobj_*.{c,h} files. The
-conversion function are in the other typecast_*.c files. typecast.c defines
-the basic utility functions (available through the psycopg module) used when
-defining new typecasters from C and python.
-
diff --git a/psycopg2.cproj b/psycopg2.cproj
index 42cfca9..7755b96 100644
--- a/psycopg2.cproj
+++ b/psycopg2.cproj
@@ -47,7 +47,6 @@
<None Include="README.rst" />
<None Include="setup.cfg" />
<None Include="setup.py" />
- <None Include="doc\HACKING" />
<None Include="doc\SUCCESS" />
<None Include="examples\binary.py" />
<None Include="examples\copy_from.py" />