summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2016-12-17 12:27:47 -0600
committerAlex Gaynor <alex.gaynor@gmail.com>2016-12-17 13:27:47 -0500
commitf5dcc37457fb4b415635713b56107a6f9ecdab72 (patch)
tree1979de131d2e4c64eff2601d1b1aaf552890124f
parentfb8d7751dd2271cdd0196631a940983ca80e900a (diff)
downloadpy-bcrypt-git-f5dcc37457fb4b415635713b56107a6f9ecdab72.tar.gz
Utf8 fix (#100)
* build with Python2 in non-utf8 environments * pep8 fix
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 060e675..3ec6579 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
#!/usr/bin/env python
+import io
import platform
import sys
from distutils.command.build import build
@@ -192,7 +193,7 @@ setup(
version=__about__["__version__"],
description=__about__["__summary__"],
- long_description=open("README.rst").read(),
+ long_description=io.open("README.rst", encoding='utf-8').read(),
url=__about__["__uri__"],
license=__about__["__license__"],