summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2022-05-01 09:46:53 -0600
committerGitHub <noreply@github.com>2022-05-01 09:46:53 -0600
commitc2c4c9bfbc24ebd3e1899831550192f02c315806 (patch)
treed1ed2bebb9ec88a0c8f05b0c21fc08b8a53b79d3
parent33f2b3f2ef98f2824fdf889e6eb2ae34baeb0192 (diff)
downloadpy-bcrypt-git-c2c4c9bfbc24ebd3e1899831550192f02c315806.tar.gz
Prepare for the 3.2.1 release (#305)
-rw-r--r--.github/workflows/ci.yml6
-rw-r--r--.github/workflows/wheel-builder.yml1
-rw-r--r--README.rst14
-rw-r--r--release.py4
-rw-r--r--setup.cfg1
-rw-r--r--src/bcrypt/__about__.py4
-rw-r--r--tox.ini1
7 files changed, 22 insertions, 9 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 8d75a19..490c98c 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -14,7 +14,7 @@ jobs:
matrix:
PYTHON:
- {VERSION: "3.6", TOXENV: "py36"}
- - {VERSION: "3.9", TOXENV: "py39"}
+ - {VERSION: "3.10", TOXENV: "py310"}
name: "Python ${{ matrix.PYTHON.VERSION }} on macOS"
steps:
- uses: actions/checkout@v2.4.0
@@ -37,7 +37,7 @@ jobs:
- {ARCH: 'x64', WINDOWS: 'win64'}
PYTHON:
- {VERSION: "3.6", TOXENV: "py36"}
- - {VERSION: "3.9", TOXENV: "py39"}
+ - {VERSION: "3.10", TOXENV: "py310"}
name: "Python ${{ matrix.PYTHON.VERSION }} on ${{ matrix.WINDOWS.WINDOWS }}"
steps:
- uses: actions/checkout@v2.4.0
@@ -62,8 +62,10 @@ jobs:
- {VERSION: "3.7", TOXENV: "py37"}
- {VERSION: "3.8", TOXENV: "py38"}
- {VERSION: "3.9", TOXENV: "py39"}
+ - {VERSION: "3.10", TOXENV: "py310"}
- {VERSION: "pypy-3.7", TOXENV: "pypy3"}
- {VERSION: "pypy-3.8", TOXENV: "pypy3"}
+ - {VERSION: "pypy-3.9", TOXENV: "pypy3"}
name: "${{ matrix.PYTHON.TOXENV }} on linux"
steps:
- uses: actions/checkout@v2.4.0
diff --git a/.github/workflows/wheel-builder.yml b/.github/workflows/wheel-builder.yml
index 3136693..972ab1d 100644
--- a/.github/workflows/wheel-builder.yml
+++ b/.github/workflows/wheel-builder.yml
@@ -18,6 +18,7 @@ jobs:
- {VERSION: "cp36-cp36m", ABI_VERSION: 'cp36'}
CONTAINER:
- {IMAGE: "cryptography-manylinux2010:x86_64", NAME: "manylinux2010"}
+ - {IMAGE: "cryptography-manylinux2014:x86_64", NAME: "manylinux2014"}
- {IMAGE: "cryptography-manylinux_2_24:x86_64", NAME: "manylinux_2_24"}
- {IMAGE: "cryptography-musllinux_1_1:x86_64", NAME: "musllinux_1_1"}
name: "${{ matrix.PYTHON.ABI_VERSION }} ${{ matrix.CONTAINER.NAME }}"
diff --git a/README.rst b/README.rst
index 3aea758..84f3759 100644
--- a/README.rst
+++ b/README.rst
@@ -49,10 +49,20 @@ While bcrypt remains a good choice for password storage depending on your specif
Changelog
=========
-UNRELEASED
-----------
+3.2.1
+-----
* Added support for compilation on z/OS
+* The next release of ``bcrypt`` with be 4.0 and it will require Rust at
+ compile time, for users building from source. There will be no additional
+ requirement for users who are installing from wheels. Users on most
+ platforms will be able to obtain a wheel by making sure they have an up to
+ date ``pip``. The minimum supported Rust version will be 1.56.0.
+* This will be the final release for which we ship ``manylinux2010`` wheels.
+ Going forward the minimum supported manylinux ABI for our wheels will be
+ ``manylinux2014``. The vast majority of users will continue to receive
+ ``manylinux`` wheels provided they have an up to date ``pip``.
+
3.2.0
-----
diff --git a/release.py b/release.py
index 8c7baf0..a79f7ca 100644
--- a/release.py
+++ b/release.py
@@ -128,11 +128,11 @@ def release(version):
run("python", "setup.py", "sdist")
packages = glob.glob("dist/bcrypt-{0}*".format(version))
- run("twine", "upload", "-s", *packages)
-
github_actions_wheel_paths = build_github_actions_wheels(
github_token, version
)
+
+ run("twine", "upload", "-s", *packages)
run("twine", "upload", *github_actions_wheel_paths)
diff --git a/setup.cfg b/setup.cfg
index 8f664d0..92b831c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -20,6 +20,7 @@ classifiers =
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
+ Programming Language :: Python :: 3.10
[options]
python_requires = >=3.6
diff --git a/src/bcrypt/__about__.py b/src/bcrypt/__about__.py
index a3e3fce..8c16ace 100644
--- a/src/bcrypt/__about__.py
+++ b/src/bcrypt/__about__.py
@@ -32,10 +32,10 @@ __title__ = "bcrypt"
__summary__ = "Modern password hashing for your software and your servers"
__uri__ = "https://github.com/pyca/bcrypt/"
-__version__ = "3.2.1.dev1"
+__version__ = "3.2.1"
__author__ = "The Python Cryptographic Authority developers"
__email__ = "cryptography-dev@python.org"
__license__ = "Apache License, Version 2.0"
-__copyright__ = "Copyright 2013-2020 {0}".format(__author__)
+__copyright__ = "Copyright 2013-2022 {0}".format(__author__)
diff --git a/tox.ini b/tox.ini
index e188dfc..36e4851 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,4 @@
[tox]
-envlist = pypy3,py36,py37,py38,py39,pep8,packaging,mypy
isolated_build = True
[testenv]