summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2022-01-05 15:24:37 -0600
committerGitHub <noreply@github.com>2022-01-05 16:24:37 -0500
commit07b9362c806b7ca7daf5ab2a7cfa8b6fe7792c54 (patch)
tree41565a2a603bf06f39354514ecb713c3882cd773
parent871e21914d3ac57b121a0780a8645aa3f75a5ae3 (diff)
downloadpy-bcrypt-git-07b9362c806b7ca7daf5ab2a7cfa8b6fe7792c54.tar.gz
goodbye qemu (#285)
* goodbye qemu * poke
-rw-r--r--.github/workflows/ci.yml21
-rw-r--r--.github/workflows/wheel-builder.yml42
2 files changed, 0 insertions, 63 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index a446525..063dd4b 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -90,24 +90,3 @@ jobs:
- run: 'tox'
env:
TOXENV: ${{ matrix.IMAGE.TOXENV }}
-
- manylinux-arm64:
- name: "${{ matrix.PYTHON.TOXENV }} on manylinux2014-aarch64"
- runs-on: ubuntu-20.04
- strategy:
- matrix:
- PYTHON:
- - {VERSION: "cp36-cp36m", TOXENV: 'py36'}
- steps:
- - uses: actions/checkout@v2.4.0
- - name: Set up QEMU
- uses: docker/setup-qemu-action@v1.2.0
- with:
- platforms: arm64
- - uses: docker://quay.io/pypa/manylinux2014_aarch64
- with:
- args: |
- bash -c "set -xe;
- /opt/python/${{ matrix.PYTHON.VERSION }}/bin/python -m venv .venv;
- .venv/bin/pip install -U tox;
- .venv/bin/tox -e ${{ matrix.PYTHON.TOXENV }};"
diff --git a/.github/workflows/wheel-builder.yml b/.github/workflows/wheel-builder.yml
index c5007a0..6334550 100644
--- a/.github/workflows/wheel-builder.yml
+++ b/.github/workflows/wheel-builder.yml
@@ -127,45 +127,3 @@ jobs:
with:
name: "bcrypt-${{ github.event.inputs.version }}-${{ matrix.WINDOWS }}-${{ matrix.PYTHON.ABI_VERSION }}"
path: bcrypt-wheelhouse\
-
- manylinux-arm64:
- name: "${{ matrix.PYTHON.ABI_VERSION }} manylinux2014-aarch64"
- runs-on: ubuntu-latest
- strategy:
- matrix:
- PYTHON:
- - {VERSION: "cp36-cp36m", ABI_VERSION: 'cp36'}
- steps:
- - uses: actions/checkout@v2.4.0
- with:
- # The tag to build or the tag received by the tag event
- ref: ${{ github.event.inputs.version || github.ref }}
- persist-credentials: false
- - run: |
- docker run --rm --privileged hypriot/qemu-register
- - uses: docker://ghcr.io/pyca/cryptography-manylinux2014_aarch64:latest
- # The weird pip cache nonsense below is due to docker ownership issues. We want
- # a cache because otherwise we end up building cffi twice.
- with:
- args: |
- bash -c "set -xe;
- mkdir -p /github/home/.cache/pip;
- chown -R $(whoami) /github/home/.cache;
- /opt/python/${{ matrix.PYTHON.VERSION }}/bin/python -m venv .venv;
- .venv/bin/pip install -U pip wheel cffi six;
- .venv/bin/python setup.py sdist;
- tar zxvf dist/bcrypt*.tar.gz;
- mkdir tmpwheelhouse;
- pushd bcrypt*;
- ../.venv/bin/python setup.py bdist_wheel --py-limited-api=${{ matrix.PYTHON.ABI_VERSION }};
- mv dist/bcrypt*.whl ../tmpwheelhouse;
- popd;
- auditwheel repair tmpwheelhouse/bcrypt*.whl -w wheelhouse/;
- .venv/bin/pip install bcrypt --no-index -f wheelhouse/;
- .venv/bin/python -c \"import bcrypt; password = b'super secret password';hashed = bcrypt.hashpw(password, bcrypt.gensalt());bcrypt.checkpw(password, hashed)\";"
- - run: mkdir bcrypt-wheelhouse
- - run: sudo mv wheelhouse/bcrypt*.whl bcrypt-wheelhouse/
- - uses: actions/upload-artifact@v1
- with:
- name: "bcrypt-${{ github.event.inputs.version }}-manylinux2014-aarch64-${{ matrix.PYTHON.ABI_VERSION }}"
- path: bcrypt-wheelhouse/