summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2020-12-19 12:21:01 -0500
committerGitHub <noreply@github.com>2020-12-19 11:21:01 -0600
commit71d92347b0c084c2b6aa1daa6a83d31c48e958a0 (patch)
tree2497288fe16d0c6a8238df5bae7b740167fcd2d9
parent7a4a24256274568f6b9734bcf70eda95b5f54cd9 (diff)
downloadpy-bcrypt-git-71d92347b0c084c2b6aa1daa6a83d31c48e958a0.tar.gz
Update our python versions to be consistent (#241)
-rw-r--r--.github/workflows/ci.yml2
-rw-r--r--pyproject.toml2
-rw-r--r--setup.py4
-rw-r--r--tests/test_bcrypt.py4
-rw-r--r--tox.ini2
5 files changed, 9 insertions, 5 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index ab6e1b1..1f12610 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -16,6 +16,7 @@ jobs:
- {VERSION: "3.6", TOXENV: "py36"}
- {VERSION: "3.7", TOXENV: "py37"}
- {VERSION: "3.8", TOXENV: "py38"}
+ - {VERSION: "3.9", TOXENV: "py39"}
name: "Python ${{ matrix.PYTHON.VERSION }} on macOS"
steps:
- uses: actions/checkout@master
@@ -40,6 +41,7 @@ jobs:
- {VERSION: "3.6", TOXENV: "py36"}
- {VERSION: "3.7", TOXENV: "py37"}
- {VERSION: "3.8", TOXENV: "py38"}
+ - {VERSION: "3.9", TOXENV: "py39"}
name: "Python ${{ matrix.PYTHON.VERSION }} on ${{ matrix.WINDOWS.WINDOWS }}"
steps:
- uses: actions/checkout@master
diff --git a/pyproject.toml b/pyproject.toml
index caa1f72..b3f9e6b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -11,4 +11,4 @@ build-backend = "setuptools.build_meta"
[tool.black]
line-length = 79
-target-version = ["py27"]
+target-version = ["py36"]
diff --git a/setup.py b/setup.py
index d521470..3536af0 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ CFFI_MODULES = [
# Manually extract the __about__
__about__ = {}
with open("src/bcrypt/__about__.py") as fp:
- exec (fp.read(), __about__)
+ exec(fp.read(), __about__)
if platform.python_implementation() == "PyPy":
@@ -66,9 +66,11 @@ setup(
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3 :: Only",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
],
ext_package="bcrypt",
cffi_modules=CFFI_MODULES,
diff --git a/tests/test_bcrypt.py b/tests/test_bcrypt.py
index 6b61576..0c4ac47 100644
--- a/tests/test_bcrypt.py
+++ b/tests/test_bcrypt.py
@@ -450,8 +450,8 @@ def test_kdf_warn_rounds():
@pytest.mark.parametrize(
("password", "salt", "desired_key_bytes", "rounds", "error"),
[
- (u"pass", b"$2b$04$cVWp4XaNU8a4v1uMRum2SO", 10, 10, TypeError),
- (b"password", u"salt", 10, 10, TypeError),
+ ("pass", b"$2b$04$cVWp4XaNU8a4v1uMRum2SO", 10, 10, TypeError),
+ (b"password", "salt", 10, 10, TypeError),
(b"", b"$2b$04$cVWp4XaNU8a4v1uMRum2SO", 10, 10, ValueError),
(b"password", b"", 10, 10, ValueError),
(b"password", b"$2b$04$cVWp4XaNU8a4v1uMRum2SO", 0, 10, ValueError),
diff --git a/tox.ini b/tox.ini
index 717c8a0..03d5beb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = pypy3,py36,py37,py38,pep8,packaging,mypy
+envlist = pypy3,py36,py37,py38,py39,pep8,packaging,mypy
isolated_build = True
[testenv]