summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorodidev <odidev@puresoftware.com>2020-08-01 20:26:18 +0530
committerGitHub <noreply@github.com>2020-08-01 09:56:18 -0500
commit9ec889b99a7d960b971caec9e6a95e1bb64a768d (patch)
treef6b5408b57b41a83efc18304a50d5e5221eb73ed
parent09c5fd1a20865731d76c607948fab5bd9c018824 (diff)
downloadpy-bcrypt-git-9ec889b99a7d960b971caec9e6a95e1bb64a768d.tar.gz
ARM64 Support to Github Actions for wheel development (#209)
Signed-off-by: odidev <odidev@puresoftware.com>
-rw-r--r--.github/workflows/wheel-builder.yml32
1 files changed, 32 insertions, 0 deletions
diff --git a/.github/workflows/wheel-builder.yml b/.github/workflows/wheel-builder.yml
index d66c191..d905618 100644
--- a/.github/workflows/wheel-builder.yml
+++ b/.github/workflows/wheel-builder.yml
@@ -116,3 +116,35 @@ jobs:
with:
name: "bcrypt-${{ github.event.client_payload.BUILD_VERSION }}-${{ matrix.WINDOWS.WINDOWS }}-${{ matrix.PYTHON.VERSION }}"
path: bcrypt-wheelhouse\
+
+ manylinux-arm64:
+ name: "Python ${{ matrix.PYTHON }} for manylinux2014-aarch64"
+ runs-on: ubuntu-latest
+ strategy:
+ matrix:
+ PYTHON: ["cp35-cp35m"]
+ fail-fast: false
+ steps:
+ - uses: actions/checkout@v2
+ - run: |
+ docker run --rm --privileged hypriot/qemu-register
+ - uses: docker://quay.io/pypa/manylinux2014_aarch64
+ with:
+ args: |
+ bash -c "/opt/python/${{ matrix.PYTHON }}/bin/pip install virtualenv;
+ /opt/python/${{ matrix.PYTHON }}/bin/python -m virtualenv .venv;
+ .venv/bin/pip install setuptools wheel cffi six;
+ REGEX='cp3([0-9])*';
+ if [[ ${{ matrix.PYTHON }} =~ $REGEX ]]; then
+ PY_LIMITED_API=\"--py-limited-api=cp3${BASH_REMATCH[1]}\";
+ fi;
+ .venv/bin/python setup.py bdist_wheel $PY_LIMITED_API -d tmpwheelhouse;
+ auditwheel repair tmpwheelhouse/bcrypt*.whl -w wheelhouse/;
+ .venv/bin/pip install bcrypt --no-index -f wheelhouse/;
+ .venv/bin/python -c \"import bcrypt; password = b'super secret password';hashed = bcrypt.hashpw(password, bcrypt.gensalt());bcrypt.checkpw(password, hashed)\";"
+ - run: mkdir bcrypt-wheelhouse
+ - run: sudo mv wheelhouse/bcrypt*.whl bcrypt-wheelhouse/
+ - uses: actions/upload-artifact@v1
+ with:
+ name: "bcrypt-${{ github.event.client_payload.BUILD_VERSION }}-manylinux2014-aarch64-${{ matrix.PYTHON }}"
+ path: bcrypt-wheelhouse/