summaryrefslogtreecommitdiff
path: root/src/_bcrypt/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/_bcrypt/Cargo.toml')
-rw-r--r--src/_bcrypt/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/_bcrypt/Cargo.toml b/src/_bcrypt/Cargo.toml
new file mode 100644
index 0000000..5849b63
--- /dev/null
+++ b/src/_bcrypt/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "bcrypt-rust"
+version = "0.1.0"
+authors = ["The bcrypt developers <cryptography-dev@python.org>"]
+edition = "2018"
+publish = false
+
+[dependencies]
+pyo3 = { version = "0.15.2" }
+bcrypt = "0.11"
+bcrypt-pbkdf = "0.8.1"
+base64 = "0.13.0"
+
+[features]
+extension-module = ["pyo3/extension-module"]
+default = ["extension-module"]
+
+[lib]
+name = "bcrypt_rust"
+crate-type = ["cdylib"]
+
+[profile.release]
+lto = "thin"
+overflow-checks = true