summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorelie <elie>2013-09-21 10:07:56 +0000
committerelie <elie>2013-09-21 10:07:56 +0000
commit2e86ae96612d7a3b4ca94524c7c25c7b6578af0f (patch)
treef5c93be4b7d44c13757805298f0579e34076a977
parent8342112691441d271465354b1b5c7dc930435f97 (diff)
downloadpyasn1-2e86ae96612d7a3b4ca94524c7c25c7b6578af0f.tar.gz
python 2.4+ installation requirement added
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 2817cbc..3382b2b 100644
--- a/setup.py
+++ b/setup.py
@@ -38,6 +38,10 @@ def howto_install_setuptools():
Then you could make eggs from this package.
""")
+if sys.version_info[:2] < (2, 4):
+ print("ERROR: this package requires Python 2.4 or later!")
+ sys.exit(1)
+
try:
from setuptools import setup, Command
params = {