summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2015-07-13 15:02:33 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2015-07-13 15:02:33 +0000
commite37d5b1ea809838ae8d2944d7c78bc7a3d35dba0 (patch)
treebe3ac6ff6707493713f50b87d521c45a0d937ba2
parentf26aaccff110b8c1a5adb9c0d01d610af60b6c08 (diff)
downloadpycadf-e37d5b1ea809838ae8d2944d7c78bc7a3d35dba0.tar.gz
Updated from global requirements
Change-Id: I1de1abf0d1881c58a91c97599315c8ac284f261d
-rw-r--r--requirements.txt8
-rw-r--r--setup.py1
-rw-r--r--test-requirements.txt14
3 files changed, 11 insertions, 12 deletions
diff --git a/requirements.txt b/requirements.txt
index 8781b75..105ed06 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -2,10 +2,10 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
Babel>=1.3
-oslo.config>=1.9.3,<1.10.0 # Apache-2.0
-oslo.context>=0.2.0,<0.3.0 # Apache-2.0
-oslo.i18n>=1.5.0,<1.6.0 # Apache-2.0
-oslo.serialization>=1.4.0,<1.5.0 # Apache-2.0
+oslo.config<1.10.0,>=1.9.3 # Apache-2.0
+oslo.context<0.3.0,>=0.2.0 # Apache-2.0
+oslo.i18n<1.6.0,>=1.5.0 # Apache-2.0
+oslo.serialization<1.5.0,>=1.4.0 # Apache-2.0
pytz>=2013.6
six>=1.9.0
WebOb>=1.2.3
diff --git a/setup.py b/setup.py
index 7363757..056c16c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
diff --git a/test-requirements.txt b/test-requirements.txt
index d9cb6eb..23100e9 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -2,18 +2,18 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
# Hacking already pins down pep8, pyflakes and flake8
-hacking>=0.10.0,<0.11
+hacking<0.11,>=0.10.0
coverage>=3.6
discover
fixtures>=0.3.14
-mock>=1.0
-oslo.messaging>=1.8.0,<1.9.0 # Apache-2.0
-oslotest>=1.5.1,<1.6.0 # Apache-2.0
+mock<1.1.0,>=1.0
+oslo.messaging<1.9.0,>=1.8.0 # Apache-2.0
+oslotest<1.6.0,>=1.5.1 # Apache-2.0
python-subunit>=0.0.18
testrepository>=0.0.18
-testtools>=0.9.36,!=1.2.0
+testtools!=1.2.0,>=0.9.36
# this is required for the docs build jobs
-oslosphinx>=2.5.0,<2.6.0 # Apache-2.0
-sphinx>=1.1.2,!=1.2.0,!=1.3b1,<1.3
+oslosphinx<2.6.0,>=2.5.0 # Apache-2.0
+sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2