summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini10
1 files changed, 2 insertions, 8 deletions
diff --git a/tox.ini b/tox.ini
index 452e361..78c0402 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,14 +1,9 @@
[tox]
minversion = 1.6
-skipsdist = True
-envlist = py26,py27,py33,py34,pep8
+envlist = py27,py33,py34,pep8
[testenv]
-setenv = VIRTUAL_ENV={envdir}
-deps = -r{toxinidir}/requirements.txt
- -r{toxinidir}/test-requirements.txt
-install_command = pip install -U {opts} {packages}
-usedevelop = True
+deps = -r{toxinidir}/test-requirements.txt
commands = python setup.py testr --slowest --testr-args='{posargs}'
[testenv:pep8]
@@ -18,7 +13,6 @@ commands = flake8
commands = python setup.py build_sphinx
[testenv:cover]
-setenv = VIRTUAL_ENV={envdir}
commands = python setup.py testr --coverage
[testenv:venv]