summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES5
-rw-r--r--README.rst2
-rw-r--r--TODO.txt19
-rw-r--r--pycparser/__init__.py2
-rw-r--r--setup.py2
5 files changed, 24 insertions, 6 deletions
diff --git a/CHANGES b/CHANGES
index d6337ac..5b0d113 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,8 @@
++ Version 2.17 (29.10.2016)
+
+ - Again functionality identical to 2.15 and 2.16; the difference is that the
+ tarball now contains Python files with properly set permissions.
+
+ Version 2.16 (18.10.2016)
- Functionally identical to 2.15, but fixes a packaging problem that caused
diff --git a/README.rst b/README.rst
index 7588cea..2d9c9a2 100644
--- a/README.rst
+++ b/README.rst
@@ -1,5 +1,5 @@
===============
-pycparser v2.16
+pycparser v2.17
===============
:Author: `Eli Bendersky <http://eli.thegreenplace.net>`_
diff --git a/TODO.txt b/TODO.txt
index 9c063e9..fe9abf4 100644
--- a/TODO.txt
+++ b/TODO.txt
@@ -6,12 +6,23 @@ Version Update
setup.py, __init__.py, README, CHANGES
- Make sure _build_tables was run in pycparser/
-- Tag in git. When pushing to GitHub, git push --tags
- If PLY version changes, note it in README and ply/LICENSE
- Run tox tests
python setup.py sdist
+Copy the newly created tarball and untar it; check that the permissions of
+Python files in the pycparser/ directory are OK. Check to see that lextab.py and
+yacctab.py are there.
+
+Now create a new virtualenv and in it install the tarball with
+`pip install <tarballname>`. See that pycparser is importable in the Python
+interpreter of this virtualenv; run pycparser tests from this virtualenv.
+
+After this it's OK to rerun `python setup.py sdist upload` to push to PyPI.
+
+- Tag in git. When pushing to GitHub, git push --tags
+
Misc
----
@@ -20,10 +31,12 @@ yacc optimization:
anyway, regardless of the optimize parameter
- If it does exist:
- If optimize=True, the table will be loaded unconditionally
- - If optimize=False, the table will be loaded only if it's older than the grammar
+ - If optimize=False, the table will be loaded only if it's older than the
+ grammar
lex optimization:
-- If optimize=False, the lexical table is re-computed and is not saved to a lextab file
+- If optimize=False, the lexical table is re-computed and is not saved to a
+ lextab file
- If optimize=True:
- If lextab.py/pyc exists in the path, it will be loaded unconditionally
- If lextab.py/pyc doesn't exist, it will be created and loaded
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index 74b2702..152a855 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -8,7 +8,7 @@
# License: BSD
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
-__version__ = '2.16'
+__version__ = '2.17'
from subprocess import Popen, PIPE
from .c_parser import CParser
diff --git a/setup.py b/setup.py
index da2cda1..07a62da 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(
C compilers or analysis tools.
""",
license='BSD',
- version='2.16',
+ version='2.17',
author='Eli Bendersky',
maintainer='Eli Bendersky',
author_email='eliben@gmail.com',