From b56e8f8be981c91be3eef1b80e6b2dfccfae57e2 Mon Sep 17 00:00:00 2001 From: "eli.bendersky" Date: Sun, 6 Mar 2011 07:56:55 +0200 Subject: preparing for release 2.03 --- README.html | 26 ++++++++++++++++++++------ README.txt | 22 ++++++++++++++++++---- TODO.txt | 14 -------------- pycparser/__init__.py | 4 ++-- setup.py | 2 +- 5 files changed, 41 insertions(+), 27 deletions(-) diff --git a/README.html b/README.html index 93969da..4830f4d 100644 --- a/README.html +++ b/README.html @@ -4,7 +4,7 @@ -pycparser v2.02 +pycparser v2.03 -
-

pycparser v2.02

+
+

pycparser v2.03

@@ -387,8 +387,8 @@ ul.auto-toc {

2.1   Prerequisites

    -
  • pycparser was tested on Python 2.5, 2.6 and 3.1, on both Linux and Windows
  • -
  • pycparser uses the PLY module for the actual lexer and parser construction. Install PLY version 3.3 (earlier versions work at least since 2.5) from its website.
  • +
  • pycparser was tested on Python 2.6 and 3.2, on both Linux and Windows. It should work on any later version (in both the 2.x and 3.x lines) as well.
  • +
  • pycparser uses the PLY module for the actual lexer and parser construction. Install PLY from its website.
@@ -413,7 +413,7 @@ ul.auto-toc {

3.2   What about the standard C library headers?

-

C code almost always includes various header files from the standard C library, like stdio.h. While, with some effort, pycparser can be made to parse the standard headers from any C compiler, it's much simpler to use the provided "fake" standard in includes in utils/fake_libc_include. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files.

+

C code almost always includes various header files from the standard C library, like stdio.h. While, with some effort, pycparser can be made to parse the standard headers from any C compiler, it's much simpler to use the provided "fake" standard includes in utils/fake_libc_include. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files.

See the using_cpp_libc.py example for more details.

@@ -463,6 +463,20 @@ ul.auto-toc {

7   Changelog

    +
  • Version 2.03 (06.03.2011)
      +
    • Bug fixes:
        +
      • Issue 17: empty file-level declarations
      • +
      • Issue 18: empty statements and declarations in functions
      • +
      • Issue 19: anonymous structs & union fields
      • +
      • Issue 23: fix coordinates of Cast nodes
      • +
      +
    • +
    • New example added (examples/c-to-c.py) for translating ASTs generated by pycparser back into C code.
    • +
    • pycparser is now on PyPI (Python Package Index)
    • +
    • Created FAQ on the pycparser project page
    • +
    • Removed support for Python 2.5. pycparser supports Python 2 from 2.6 and on, and Python 3.
    • +
    +
  • Version 2.02 (10.12.2010)
    • The name of a NamedInitializer node was turned into a sequence of nodes instead of an attribute, to make it discoverable by the AST node visitor.
    • diff --git a/README.txt b/README.txt index 9318211..3e7ae1f 100644 --- a/README.txt +++ b/README.txt @@ -1,5 +1,5 @@ =============== -pycparser v2.02 +pycparser v2.03 =============== :Author: `Eli Bendersky `_ @@ -62,8 +62,8 @@ Installing Prerequisites ------------- -* ``pycparser`` was tested on Python 2.5, 2.6 and 3.1, on both Linux and Windows -* ``pycparser`` uses the PLY module for the actual lexer and parser construction. Install PLY version 3.3 (earlier versions work at least since 2.5) from `its website `_. +* ``pycparser`` was tested on Python 2.6 and 3.2, on both Linux and Windows. It should work on any later version (in both the 2.x and 3.x lines) as well. +* ``pycparser`` uses the PLY module for the actual lexer and parser construction. Install PLY from `its website `_. Installation process -------------------- @@ -92,7 +92,7 @@ On the vast majority of Linux systems, ``cpp`` is installed and is in the PATH. What about the standard C library headers? ------------------------------------------ -C code almost always includes various header files from the standard C library, like ``stdio.h``. While, with some effort, ``pycparser`` can be made to parse the standard headers from any C compiler, it's much simpler to use the provided "fake" standard in includes in ``utils/fake_libc_include``. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files. +C code almost always includes various header files from the standard C library, like ``stdio.h``. While, with some effort, ``pycparser`` can be made to parse the standard headers from any C compiler, it's much simpler to use the provided "fake" standard includes in ``utils/fake_libc_include``. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files. See the ``using_cpp_libc.py`` example for more details. @@ -154,6 +154,20 @@ Some people have contributed to ``pycparser`` by opening issues on bugs they've Changelog ========= ++ Version 2.03 (06.03.2011) + + - Bug fixes: + + * Issue 17: empty file-level declarations + * Issue 18: empty statements and declarations in functions + * Issue 19: anonymous structs & union fields + * Issue 23: fix coordinates of Cast nodes + + - New example added (``examples/c-to-c.py``) for translating ASTs generated by ``pycparser`` back into C code. + - ``pycparser`` is now on PyPI (Python Package Index) + - Created `FAQ `_ on the ``pycparser`` project page + - Removed support for Python 2.5. ``pycparser`` supports Python 2 from 2.6 and on, and Python 3. + + Version 2.02 (10.12.2010) * The name of a ``NamedInitializer`` node was turned into a sequence of nodes diff --git a/TODO.txt b/TODO.txt index 67f1a2e..340cb71 100644 --- a/TODO.txt +++ b/TODO.txt @@ -1,20 +1,6 @@ Todo ---- -* move changelist to wiki maybe? - - -Fixes since last: ------------------- - -* Issue 17: empty file-level declarations -* Issue 18: empty statements and declarations in functions -* Issue 19: anonymous structs & union fields -* Issue 23: fix coordinates of Cast nodes -* pycparser is now on PyPI (Python Package Index) -* Created FAQ on the pycparser project page - the readme now points to it -* No support for Python 2.5, only starting with 2.6 and 3.x - Version Update -------------- diff --git a/pycparser/__init__.py b/pycparser/__init__.py index 9ee571e..c86b294 100644 --- a/pycparser/__init__.py +++ b/pycparser/__init__.py @@ -4,12 +4,12 @@ # This package file exports some convenience functions for # interacting with pycparser # -# Copyright (C) 2008-2010, Eli Bendersky +# Copyright (C) 2008-2011, Eli Bendersky # License: LGPL #----------------------------------------------------------------- __all__ = ['c_lexer', 'c_parser', 'c_ast'] -__version__ = '2.02' +__version__ = '2.03' from subprocess import Popen, PIPE diff --git a/setup.py b/setup.py index 8cc88ac..ae36646 100644 --- a/setup.py +++ b/setup.py @@ -14,7 +14,7 @@ setup( """, install_requires=['ply'], license='LGPL', - version='2.02', + version='2.03', author='Eli Bendersky', maintainer='Eli Bendersky', author_email='eliben@gmail.com', -- cgit v1.2.1