summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Abramowitz <marc@marc-abramowitz.com>2013-11-10 16:10:30 +0000
committerDwayne Litzenberger <dlitz@dlitz.net>2016-04-01 17:47:17 -0700
commit0bd4a81fcdcef2f0c693dbf37c3501f5e5ed88f0 (patch)
tree3393087b738e297092981331bd47cdf160975f25
parent7a3277f50cd974072d6b1f9da317ef502c5fa6f6 (diff)
downloadpycrypto-0bd4a81fcdcef2f0c693dbf37c3501f5e5ed88f0.tar.gz
Add support for tox
-rw-r--r--.gitignore3
-rw-r--r--tox.ini10
2 files changed, 13 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index 95b79c0..be71c21 100644
--- a/.gitignore
+++ b/.gitignore
@@ -18,3 +18,6 @@ src/config.h
# Backup files
*~
+
+# Tox
+.tox
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..56738d4
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,10 @@
+# Tox (http://tox.testrun.org/) is a tool for running tests
+# in multiple virtualenvs. This configuration file will run the
+# test suite on all supported python versions. To use it, "pip install tox"
+# and then run "tox" from this directory.
+
+[tox]
+envlist = py25, py26, py27, py32, py33, py34, pypy
+
+[testenv]
+commands = {envpython} setup.py test