summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDwayne Litzenberger <dlitz@dlitz.net>2016-04-01 22:59:46 -0700
committerDwayne Litzenberger <dlitz@dlitz.net>2016-04-01 22:59:46 -0700
commit25181c4afd189abcab0de00018ce3fbb29b0c89f (patch)
treecd2b891c796c4b37783e9a3cc54b0e77fc49f6ed
parentbe23a3588297b2604f5aa4891dc8e4c96dd20fc5 (diff)
downloadpycrypto-25181c4afd189abcab0de00018ce3fbb29b0c89f.tar.gz
Add default appveyor.yml
Downloaded from https://raw.githubusercontent.com/pypa/python-packaging-user-guide/master/source/code/appveyor.yml
-rw-r--r--appveyor.yml51
1 files changed, 51 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 0000000..44856ab
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,51 @@
+environment:
+
+ matrix:
+
+ # For Python versions available on Appveyor, see
+ # http://www.appveyor.com/docs/installed-software#python
+ # The list here is complete (excluding Python 2.6, which
+ # isn't covered by this document) at the time of writing.
+
+ - PYTHON: "C:\\Python27"
+ - PYTHON: "C:\\Python33"
+ - PYTHON: "C:\\Python34"
+ - PYTHON: "C:\\Python35"
+ - PYTHON: "C:\\Python27-x64"
+ - PYTHON: "C:\\Python33-x64"
+ DISTUTILS_USE_SDK: "1"
+ - PYTHON: "C:\\Python34-x64"
+ DISTUTILS_USE_SDK: "1"
+ - PYTHON: "C:\\Python35-x64"
+
+install:
+ # We need wheel installed to build wheels
+ - "%PYTHON%\\python.exe -m pip install wheel"
+
+build: off
+
+test_script:
+ # Put your test command here.
+ # If you don't need to build C extensions on 64-bit Python 3.3 or 3.4,
+ # you can remove "build.cmd" from the front of the command, as it's
+ # only needed to support those cases.
+ # Note that you must use the environment variable %PYTHON% to refer to
+ # the interpreter you're using - Appveyor does not do anything special
+ # to put the Python evrsion you want to use on PATH.
+ - "build.cmd %PYTHON%\\python.exe setup.py test"
+
+after_test:
+ # This step builds your wheels.
+ # Again, you only need build.cmd if you're building C extensions for
+ # 64-bit Python 3.3/3.4. And you need to use %PYTHON% to get the correct
+ # interpreter
+ - "build.cmd %PYTHON%\\python.exe setup.py bdist_wheel"
+
+artifacts:
+ # bdist_wheel puts your built wheel in the dist directory
+ - path: dist\*
+
+#on_success:
+# You can use this step to upload your artifacts to a public website.
+# See Appveyor's documentation for more details. Or you can simply
+# access your wheels from the Appveyor "artifacts" tab for your build.