summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Noseevich <ngo@solidlab.ru>2015-07-06 20:28:49 +0300
committerDwayne Litzenberger <dlitz@dlitz.net>2016-04-02 00:24:08 -0700
commit6ef497e67d340df37f5ede797247e8f9ede88679 (patch)
tree275a0c8205e97cfc9a430ccbcb590f61830bad91
parent6b604ef6a3110ac0a39206c382a4153c24ac752c (diff)
downloadpycrypto-6ef497e67d340df37f5ede797247e8f9ede88679.tar.gz
setup.py: if possible, use setuptools
This helps to build wheels
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index c9a09db..6701f9e 100644
--- a/setup.py
+++ b/setup.py
@@ -35,12 +35,15 @@
# ===================================================================
__revision__ = "$Id$"
-
-from distutils import core
+try:
+ import setuptools as core
+except ImportError:
+ from distutils import core
from distutils.ccompiler import new_compiler
from distutils.core import Extension, Command
from distutils.command.build import build
from distutils.command.build_ext import build_ext
+
import os, sys, re
import struct