summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2012-05-24 07:41:30 -0400
committerDwayne C. Litzenberger <dlitz@dlitz.net>2012-05-24 07:41:30 -0400
commitdaeea7879651877c771b2bb3e44b9e5d3379e395 (patch)
tree11d52871745b38d09ae04054aae4f03fff3c6adb
parentcc990c02f3297342c6f059a8795b9790de0751f2 (diff)
downloadpycrypto-daeea7879651877c771b2bb3e44b9e5d3379e395.tar.gz
Remove -std=c99 when building using aCC compiler HP-UX
Bug report: https://bugs.launchpad.net/pycrypto/+bug/980358
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index daa3a4d..7506b8f 100644
--- a/setup.py
+++ b/setup.py
@@ -117,6 +117,10 @@ class PCTBuildExt (build_ext):
# Tell GCC to compile using the C99 standard.
self.__add_compiler_option("-std=c99")
+ # ... but don't tell that to the aCC compiler on HP-UX
+ if self.compiler.compiler_so[0] == 'cc' and sys.platform.startswith('hp-ux'):
+ self.__remove_compiler_option("-std=c99")
+
# Make assert() statements always work
self.__remove_compiler_option("-DNDEBUG")