summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2010-05-29 10:13:54 -0400
committerDwayne C. Litzenberger <dlitz@dlitz.net>2010-05-29 10:13:56 -0400
commit574ffac9f5d290933e8c0678c430fa8eabc962d0 (patch)
tree78a357fbf1d440af5c459d2109d237feec621621
parent6dec36f2324f29aa0acc598564a1a0eb8348fd73 (diff)
downloadpycrypto-574ffac9f5d290933e8c0678c430fa8eabc962d0.tar.gz
Tell GCC to compile using the C99 standard
This should fix building on FreeBSD and NetBSD.
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9346a3d..67d8c59 100644
--- a/setup.py
+++ b/setup.py
@@ -121,6 +121,9 @@ class PCTBuildExt (build_ext):
# Tweak compiler options
if self.compiler.compiler_type in ('unix', 'cygwin', 'mingw32'):
+ # Tell GCC to compile using the C99 standard.
+ self.__add_compiler_option("-std=c99")
+
# Make assert() statements always work
self.__remove_compiler_option("-DNDEBUG")