summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2011-10-10 15:01:00 -0400
committerDwayne C. Litzenberger <dlitz@dlitz.net>2011-10-10 16:22:44 -0400
commit32114297da2450af00c4612596bc15da4f6256f2 (patch)
tree40d63e1783c9d6d795a3fa542345d04b7dfba8ea
parent0f79b994837d0bac9023b716d7b3cd8e45d946cf (diff)
downloadpycrypto-32114297da2450af00c4612596bc15da4f6256f2.tar.gz
Update ACKS and ChangeLog
-rw-r--r--ACKS7
-rw-r--r--ChangeLog27
2 files changed, 34 insertions, 0 deletions
diff --git a/ACKS b/ACKS
index a2ad265..558fbd1 100644
--- a/ACKS
+++ b/ACKS
@@ -16,16 +16,20 @@ Please let me know if your name isn't here and should be!
Nevins Bartolomeo
Thorsten E. Behrens
Tim Berners-Lee
+Frédéric Bertolus
Ian Bicking
Joris Bontje
Antoon Bosselaers
Andrea Bottoni
Sergey Chernov
+Geremy Condra
+Jan Dittberner
Andrew Eland
Philippe Frycia
Peter Gutmann
Hirendra Hindocha
Nikhil Jhingan
+Ryan Kelly
Andrew M. Kuchling
Piers Lauder
M.-A. Lemburg
@@ -37,11 +41,14 @@ Wallace Owen
Colin Plumb
Robey Pointer
Lorenz Quack
+Sebastian Ramacher
Jeethu Rao
James P. Rutledge
Matt Schreiner
Peter Simmons
+Janne Snabb
Tom St. Denis
+Anders Sundman
Paul Swartz
Kevin M. Turner
Barry A. Warsaw
diff --git a/ChangeLog b/ChangeLog
index 8075b68..1282e75 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,30 @@
+2.4
+===
+ * Python 3 support! (Thorsten E. Behrens, Anders Sundman)
+ PyCrypto now supports every version of Python from 2.1 through 3.2.
+
+ * Timing-attack countermeasures in _fastmath: When built against
+ libgmp version 5 or later, we use mpz_powm_sec instead of mpz_powm.
+ This should prevent the timing attack described by Geremy Condra at
+ PyCon 2011:
+ http://blip.tv/pycon-us-videos-2009-2010-2011/pycon-2011-through-the-side-channel-timing-and-implementation-attacks-in-python-4897955
+
+ * New hash modules (for Python >= 2.5 only): SHA224, SHA384, and
+ SHA512 (Frédéric Bertolus)
+
+ * Improve the test command in setup.py, by allowing tests to be
+ performed on a single sub-package or module only. (Legrandin)
+
+ * Fix double-decref of "counter" when Cipher object initialisation
+ fails (Ryan Kelly)
+
+ * Apply patches from Debian's python-crypto 2.3-3 package (Jan
+ Dittberner, Sebastian Ramacher):
+ - fix-RSA-generate-exception.patch
+ - epydoc-exclude-introspect.patch
+ - no-usr-local.patch
+
+
2.3
===
* Fix NameError when attempting to use deprecated getRandomNumber()