summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLegrandin <gooksankoo@hoiptorrow.mailexpire.com>2011-10-19 23:13:42 +0200
committerLegrandin <gooksankoo@hoiptorrow.mailexpire.com>2011-10-19 23:13:42 +0200
commit3b5e3e152a24c1a184cdb94023e37cbcbe5c7da4 (patch)
tree0c02c17476be49c4fddc99122da5bcefa4fe7491
parent8390495a9d7c574213fbff51af6f2aea249d81c7 (diff)
parent0b370a7aea9c67bc9e69408598f57ca71e091509 (diff)
downloadpycrypto-3b5e3e152a24c1a184cdb94023e37cbcbe5c7da4.tar.gz
Merge from upstream
-rw-r--r--ChangeLog13
-rw-r--r--lib/Crypto/PublicKey/RSA.py2
2 files changed, 15 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 1282e75..b112a20 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -12,9 +12,18 @@
* New hash modules (for Python >= 2.5 only): SHA224, SHA384, and
SHA512 (Frédéric Bertolus)
+ * Configuration using GNU autoconf. This should help fix a bunch of
+ build issues.
+
+ * Support using MPIR as an alternative to GMP.
+
* Improve the test command in setup.py, by allowing tests to be
performed on a single sub-package or module only. (Legrandin)
+ You can now do something like this:
+
+ python setup.py test -m Hash.SHA256 --skip-slow-tests
+
* Fix double-decref of "counter" when Cipher object initialisation
fails (Ryan Kelly)
@@ -24,6 +33,10 @@
- epydoc-exclude-introspect.patch
- no-usr-local.patch
+ * Fix launchpad bug #702835: "Import key code is not compatible with
+ GMP library" (Legrandin)
+
+ * More tests, better documentation, various bugfixes.
2.3
===
diff --git a/lib/Crypto/PublicKey/RSA.py b/lib/Crypto/PublicKey/RSA.py
index 981b239..1e3a433 100644
--- a/lib/Crypto/PublicKey/RSA.py
+++ b/lib/Crypto/PublicKey/RSA.py
@@ -48,6 +48,8 @@ import struct
from Crypto.Util.number import inverse
+from Crypto.Util.number import inverse
+
try:
from Crypto.PublicKey import _fastmath
except ImportError: