diff options
author | Dwayne C. Litzenberger <dlitz@dlitz.net> | 2011-10-10 15:09:31 -0400 |
---|---|---|
committer | Dwayne C. Litzenberger <dlitz@dlitz.net> | 2011-10-10 16:05:23 -0400 |
commit | c263294fe7707abec2550275a8c6dc994869f3b8 (patch) | |
tree | 663bcbff2bf976bf240d72ef4752a66dc567407d /setup.py | |
parent | bf38995ffa51e28b8232e9417b450a8edbd23dec (diff) | |
download | pycrypto-c263294fe7707abec2550275a8c6dc994869f3b8.tar.gz |
setup.py: Don't run ./configure if ./config.status already exists
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 5 insertions, 4 deletions
@@ -265,10 +265,11 @@ class PCTBuildConfigure(Command): pass def run(self): - if os.system("chmod 0755 configure") != 0: - raise RuntimeError("chmod error") - if os.system("./configure") != 0: - raise RuntimeError("autoconf error") + if not os.path.exists("config.status"): + if os.system("chmod 0755 configure") != 0: + raise RuntimeError("chmod error") + if os.system("./configure") != 0: + raise RuntimeError("autoconf error") class PCTBuildPy(build_py): def find_package_modules(self, package, package_dir, *args, **kwargs): |