summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index daa3a4d..7506b8f 100644
--- a/setup.py
+++ b/setup.py
@@ -117,6 +117,10 @@ class PCTBuildExt (build_ext):
# Tell GCC to compile using the C99 standard.
self.__add_compiler_option("-std=c99")
+ # ... but don't tell that to the aCC compiler on HP-UX
+ if self.compiler.compiler_so[0] == 'cc' and sys.platform.startswith('hp-ux'):
+ self.__remove_compiler_option("-std=c99")
+
# Make assert() statements always work
self.__remove_compiler_option("-DNDEBUG")