summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5af83ac..ca896bb 100644
--- a/setup.py
+++ b/setup.py
@@ -118,6 +118,10 @@ class PCTBuildExt (build_ext):
# Make assert() statements always work
self.__remove_compiler_option("-DNDEBUG")
+ # mingw32's compiler no longer supports this option
+ if self.compiler.compiler_type == 'mingw32':
+ self.__remove_compiler_option("-mno-cygwin")
+
if USE_GCOV: # TODO - move this to configure.ac
self.__add_compiler_option("-fprofile-arcs")
self.__add_compiler_option("-ftest-coverage")