summaryrefslogtreecommitdiff
path: root/pipermail/pycrypto/2012q2/000609.html
diff options
context:
space:
mode:
Diffstat (limited to 'pipermail/pycrypto/2012q2/000609.html')
-rw-r--r--pipermail/pycrypto/2012q2/000609.html157
1 files changed, 157 insertions, 0 deletions
diff --git a/pipermail/pycrypto/2012q2/000609.html b/pipermail/pycrypto/2012q2/000609.html
new file mode 100644
index 0000000..e61e217
--- /dev/null
+++ b/pipermail/pycrypto/2012q2/000609.html
@@ -0,0 +1,157 @@
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
+<HTML>
+ <HEAD>
+ <TITLE> [pycrypto] problems with testing PyCrypto Module
+ </TITLE>
+ <LINK REL="Index" HREF="index.html" >
+ <LINK REL="made" HREF="mailto:pycrypto%40lists.dlitz.net?Subject=Re%3A%20%5Bpycrypto%5D%20problems%20with%20testing%20PyCrypto%20Module&In-Reply-To=%3CF08FBCAD-72C7-45E3-A57D-D91284AAB249%40dell.com%3E">
+ <META NAME="robots" CONTENT="index,nofollow">
+ <style type="text/css">
+ pre {
+ white-space: pre-wrap; /* css-2.1, curent FF, Opera, Safari */
+ }
+ </style>
+ <META http-equiv="Content-Type" content="text/html; charset=us-ascii">
+ <LINK REL="Previous" HREF="000608.html">
+ <LINK REL="Next" HREF="000610.html">
+ </HEAD>
+ <BODY BGCOLOR="#ffffff">
+ <H1>[pycrypto] problems with testing PyCrypto Module</H1>
+ <B>Paul_Koning at Dell.com</B>
+ <A HREF="mailto:pycrypto%40lists.dlitz.net?Subject=Re%3A%20%5Bpycrypto%5D%20problems%20with%20testing%20PyCrypto%20Module&In-Reply-To=%3CF08FBCAD-72C7-45E3-A57D-D91284AAB249%40dell.com%3E"
+ TITLE="[pycrypto] problems with testing PyCrypto Module">Paul_Koning at Dell.com
+ </A><BR>
+ <I>Tue Jun 26 11:50:52 EDT 2012</I>
+ <P><UL>
+ <LI>Previous message: <A HREF="000608.html">[pycrypto] problems with testing PyCrypto Module
+</A></li>
+ <LI>Next message: <A HREF="000610.html">[pycrypto] problems with testing PyCrypto Module
+</A></li>
+ <LI> <B>Messages sorted by:</B>
+ <a href="date.html#609">[ date ]</a>
+ <a href="thread.html#609">[ thread ]</a>
+ <a href="subject.html#609">[ subject ]</a>
+ <a href="author.html#609">[ author ]</a>
+ </LI>
+ </UL>
+ <HR>
+<!--beginarticle-->
+<PRE>Maybe it was waiting for /dev/random to think it had enough entropy to work?
+
+paul
+
+On Jun 26, 2012, at 11:47 AM, Philip Anil-QBW348 wrote:
+
+After a long time (1 hr) and hitting [enter]:
+
+D:\Cryptolibrary\pycrypto-2.6&gt;python setup.py build
+running build
+running build_py
+running build_ext
+warning: GMP or MPIR library not found; Not building Crypto.PublicKey._fastmath.
+
+D:\Cryptolibrary\pycrypto-2.6&gt;python setup.py test
+running test
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+............................................SelfTest: You can ignore the RandomPool_DeprecationWarning that follows.
+.........E...................
+======================================================================
+ERROR: test_negative_number_roundtrip_mpzToLongObj_longObjToMPZ (Crypto.SelfTest.Util.test_number.MiscTests)
+Test that mpzToLongObj and longObjToMPZ (internal functions) roundtrip negative numbers correctly.
+----------------------------------------------------------------------
+Traceback (most recent call last):
+ File &quot;build\lib.win32-2.7\Crypto\SelfTest\Util\test_number.py&quot;, line 283, in test_negative_number_roundtrip_mpzToLongO
+bj_longObjToMPZ
+ k = number._fastmath.rsa_construct(n, e)
+AttributeError: 'NoneType' object has no attribute 'rsa_construct'
+
+----------------------------------------------------------------------
+Ran 1033 tests in 3513.075s
+
+FAILED (errors=1)
+Traceback (most recent call last):
+ File &quot;setup.py&quot;, line 456, in &lt;module&gt;
+ core.setup(**kw)
+ File &quot;C:\Python27\lib\distutils\core.py&quot;, line 152, in setup
+ dist.run_commands()
+ File &quot;C:\Python27\lib\distutils\dist.py&quot;, line 953, in run_commands
+ self.run_command(cmd)
+ File &quot;C:\Python27\lib\distutils\dist.py&quot;, line 972, in run_command
+ cmd_obj.run()
+ File &quot;setup.py&quot;, line 336, in run
+ SelfTest.run(module=moduleObj, verbosity=self.verbose, stream=sys.stdout, config=self.config)
+ File &quot;build\lib.win32-2.7\Crypto\SelfTest\__init__.py&quot;, line 74, in run
+ raise SelfTestError(&quot;Self-test failed&quot;, result)
+Crypto.SelfTest.SelfTestError: ('Self-test failed', &lt;unittest.runner.TextTestResult run=1033 errors=1 failures=0&gt;)
+
+
+
+From: <A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto-bounces at lists.dlitz.net</A>&lt;mailto:<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto-bounces at lists.dlitz.net</A>&gt; [mailto:<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto-bounces at lists.dlitz.net</A>] On Behalf Of Philip Anil-QBW348
+Sent: Tuesday, June 26, 2012 9:50 AM
+To: PyCrypto discussion list
+Subject: Re: [pycrypto] problems with testing PyCrypto Module
+
+D: \pycrypto-2.6&gt;python setup.py build
+running build
+running build_py
+running build_ext
+warning: GMP or MPIR library not found; Not building Crypto.PublicKey._fastmath.
+
+D: \pycrypto-2.6&gt;python setup.py test
+running test
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+........................................................................................................................
+...............................................................................................................
+
+From: <A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto-bounces at lists.dlitz.net</A>&lt;mailto:<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto-bounces at lists.dlitz.net</A>&gt; [mailto:<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto-bounces at lists.dlitz.net</A>] On Behalf Of Philip Anil-QBW348
+Sent: Monday, June 25, 2012 5:21 PM
+To: <A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto at lists.dlitz.net</A>&lt;mailto:<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto at lists.dlitz.net</A>&gt;
+Subject: [pycrypto] problems with testing PyCrypto Module
+
+
+Python newbie here.
+
+Win XP with VS 2008 installed.
+
+I ran the commands from the README for PyCrypto. No errors reported. python setup.py test produces lots of ................. and then hangs. No message saying &quot;all tests passed&quot; or whatever.
+
+
+_______________________________________________
+pycrypto mailing list
+<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto at lists.dlitz.net</A>&lt;mailto:<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto at lists.dlitz.net</A>&gt;
+<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto</A>
+
+</PRE>
+
+
+<!--endarticle-->
+ <HR>
+ <P><UL>
+ <!--threads-->
+ <LI>Previous message: <A HREF="000608.html">[pycrypto] problems with testing PyCrypto Module
+</A></li>
+ <LI>Next message: <A HREF="000610.html">[pycrypto] problems with testing PyCrypto Module
+</A></li>
+ <LI> <B>Messages sorted by:</B>
+ <a href="date.html#609">[ date ]</a>
+ <a href="thread.html#609">[ thread ]</a>
+ <a href="subject.html#609">[ subject ]</a>
+ <a href="author.html#609">[ author ]</a>
+ </LI>
+ </UL>
+
+<hr>
+<a href="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">More information about the pycrypto
+mailing list</a><br>
+</body></html>