summaryrefslogtreecommitdiff
path: root/pipermail/pycrypto/2015q2/000835.html
diff options
context:
space:
mode:
Diffstat (limited to 'pipermail/pycrypto/2015q2/000835.html')
-rw-r--r--pipermail/pycrypto/2015q2/000835.html122
1 files changed, 122 insertions, 0 deletions
diff --git a/pipermail/pycrypto/2015q2/000835.html b/pipermail/pycrypto/2015q2/000835.html
new file mode 100644
index 0000000..41b7e09
--- /dev/null
+++ b/pipermail/pycrypto/2015q2/000835.html
@@ -0,0 +1,122 @@
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
+<HTML>
+ <HEAD>
+ <TITLE> [pycrypto] python 3, crypto installation issue?
+ </TITLE>
+ <LINK REL="Index" HREF="index.html" >
+ <LINK REL="made" HREF="mailto:pycrypto%40lists.dlitz.net?Subject=Re%3A%20%5Bpycrypto%5D%20python%203%2C%20crypto%20installation%20issue%3F&In-Reply-To=%3C554cf506.2341440a.47fb.0a31%40mx.google.com%3E">
+ <META NAME="robots" CONTENT="index,nofollow">
+ <style type="text/css">
+ pre {
+ white-space: pre-wrap; /* css-2.1, curent FF, Opera, Safari */
+ }
+ </style>
+ <META http-equiv="Content-Type" content="text/html; charset=us-ascii">
+ <LINK REL="Previous" HREF="000834.html">
+ <LINK REL="Next" HREF="000836.html">
+ </HEAD>
+ <BODY BGCOLOR="#ffffff">
+ <H1>[pycrypto] python 3, crypto installation issue?</H1>
+ <B>mark grandi</B>
+ <A HREF="mailto:pycrypto%40lists.dlitz.net?Subject=Re%3A%20%5Bpycrypto%5D%20python%203%2C%20crypto%20installation%20issue%3F&In-Reply-To=%3C554cf506.2341440a.47fb.0a31%40mx.google.com%3E"
+ TITLE="[pycrypto] python 3, crypto installation issue?">markgrandi at gmail.com
+ </A><BR>
+ <I>Fri May 8 10:40:06 PDT 2015</I>
+ <P><UL>
+ <LI>Previous message: <A HREF="000834.html">[pycrypto] python 3, crypto installation issue?
+</A></li>
+ <LI>Next message: <A HREF="000836.html">[pycrypto] python 3, crypto installation issue?
+</A></li>
+ <LI> <B>Messages sorted by:</B>
+ <a href="date.html#835">[ date ]</a>
+ <a href="thread.html#835">[ thread ]</a>
+ <a href="subject.html#835">[ subject ]</a>
+ <a href="author.html#835">[ author ]</a>
+ </LI>
+ </UL>
+ <HR>
+<!--beginarticle-->
+<PRE>The pyyaml package tries to see if yaml.h is installed for optional speedups, but i know the pyyaml package can work without the c extensions, maybe the pycrypto installer doesn't handle that case?
+
+~mark
+
+-----Original Message-----
+From: &quot;Dave Pawson&quot; &lt;<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">dave.pawson at gmail.com</A>&gt;
+Sent: &#8206;5/&#8206;8/&#8206;2015 4:23 AM
+To: &quot;Pycrypto List&quot; &lt;<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto at lists.dlitz.net</A>&gt;
+Subject: [pycrypto] python 3, crypto installation issue?
+
+Linux, as root.
+$ pip3 install Crypto
+...
+
+Installing collected packages: Crypto, Naked, pyyaml
+ Running setup.py install for pyyaml
+ checking if libyaml is compilable
+ gcc -pthread -Wno-unused-result -DDYNAMIC_ANNOTATIONS_ENABLED=1
+-DNDEBUG -O2 -g -pipe -Wall -Werror=format-security
+-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong
+--param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic
+-D_GNU_SOURCE -fPIC -fwrapv -fPIC -I/usr/include/python3.4m -c
+build/temp.linux-x86_64-3.4/check_libyaml.c -o
+build/temp.linux-x86_64-3.4/check_libyaml.o
+ build/temp.linux-x86_64-3.4/check_libyaml.c:2:18: fatal error:
+yaml.h: No such file or directory
+ #include &lt;yaml.h&gt;
+ ^
+ compilation terminated.
+
+ libyaml is not found or a compiler error: forcing --without-libyaml
+ (if libyaml is installed correctly, you may need to
+ specify the option --include-dirs or uncomment and
+ modify the parameter include_dirs in setup.cfg)
+
+Suggestions please?
+
+$pip3 search pyyaml
+pyaml - PyYAML-based module to produce
+ pretty and readable YAML-
+ serialized data
+PyYAML - YAML parser and emitter for
+ Python
+ INSTALLED: 3.11 (latest)
+
+So it seems I have pyyaml installed?
+
+TiA
+
+--
+Dave Pawson
+XSLT XSL-FO FAQ.
+Docbook FAQ.
+<A HREF="http://www.dpawson.co.uk">http://www.dpawson.co.uk</A>
+_______________________________________________
+pycrypto mailing list
+<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">pycrypto at lists.dlitz.net</A>
+<A HREF="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto</A>
+-------------- next part --------------
+An HTML attachment was scrubbed...
+URL: &lt;<A HREF="http://lists.dlitz.net/pipermail/pycrypto/attachments/20150508/688aa5f9/attachment.html">http://lists.dlitz.net/pipermail/pycrypto/attachments/20150508/688aa5f9/attachment.html</A>&gt;
+</PRE>
+
+
+<!--endarticle-->
+ <HR>
+ <P><UL>
+ <!--threads-->
+ <LI>Previous message: <A HREF="000834.html">[pycrypto] python 3, crypto installation issue?
+</A></li>
+ <LI>Next message: <A HREF="000836.html">[pycrypto] python 3, crypto installation issue?
+</A></li>
+ <LI> <B>Messages sorted by:</B>
+ <a href="date.html#835">[ date ]</a>
+ <a href="thread.html#835">[ thread ]</a>
+ <a href="subject.html#835">[ subject ]</a>
+ <a href="author.html#835">[ author ]</a>
+ </LI>
+ </UL>
+
+<hr>
+<a href="http://lists.dlitz.net/cgi-bin/mailman/listinfo/pycrypto">More information about the pycrypto
+mailing list</a><br>
+</body></html>