summaryrefslogtreecommitdiff
path: root/pipermail/pycrypto/attachments/20100303/0ec61fb2/attachment.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pipermail/pycrypto/attachments/20100303/0ec61fb2/attachment.txt')
-rw-r--r--pipermail/pycrypto/attachments/20100303/0ec61fb2/attachment.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/pipermail/pycrypto/attachments/20100303/0ec61fb2/attachment.txt b/pipermail/pycrypto/attachments/20100303/0ec61fb2/attachment.txt
new file mode 100644
index 0000000..28b66b2
--- /dev/null
+++ b/pipermail/pycrypto/attachments/20100303/0ec61fb2/attachment.txt
@@ -0,0 +1,24 @@
+diff -r pycrypto-2.x/setup.py ../../PyCrypto3/PyCryptoOrig/pycrypto-2.x/setup.py
+45c45
+< if sys.version[0:1] == '1':
+---
+> if sys.version[0:1] != '3':
+47c47
+< "Python 2.x to build.")
+---
+> "Python 3.x to build.")
+diff -r pycrypto-2.x/src/_counter.c ../../PyCrypto3/PyCryptoOrig/pycrypto-2.x/src/_counter.c
+439c439
+< init_counter(void)
+---
+> PyInit__counter(void)
+diff -r pycrypto-2.x/src/strxor.c ../../PyCrypto3/PyCryptoOrig/pycrypto-2.x/src/strxor.c
+228c228
+< initstrxor(void)
+---
+> PyInit_strxor(void)
+diff -r pycrypto-2.x/src/winrand.c ../../PyCrypto3/PyCryptoOrig/pycrypto-2.x/src/winrand.c
+225c225
+< initwinrandom()
+---
+> PyInit_winrandom()