summaryrefslogtreecommitdiff
path: root/pipermail/pycrypto/attachments/20140402/117d4813/attachment.html
diff options
context:
space:
mode:
Diffstat (limited to 'pipermail/pycrypto/attachments/20140402/117d4813/attachment.html')
-rw-r--r--pipermail/pycrypto/attachments/20140402/117d4813/attachment.html13
1 files changed, 13 insertions, 0 deletions
diff --git a/pipermail/pycrypto/attachments/20140402/117d4813/attachment.html b/pipermail/pycrypto/attachments/20140402/117d4813/attachment.html
new file mode 100644
index 0000000..74cd1b4
--- /dev/null
+++ b/pipermail/pycrypto/attachments/20140402/117d4813/attachment.html
@@ -0,0 +1,13 @@
+<tt>
+&lt;div&nbsp;dir=&quot;ltr&quot;&gt;&lt;div&gt;I&nbsp;have&nbsp;a&nbsp;patch&nbsp;to&nbsp;suggest.&nbsp;Both&nbsp;on&nbsp;a&nbsp;linux&nbsp;system&nbsp;and&nbsp;an&nbsp;OS&nbsp;X&nbsp;system&nbsp;that&nbsp;I&nbsp;have&nbsp;access&nbsp;to,&nbsp;if&nbsp;my&nbsp;PATH&nbsp;contains&nbsp;another&nbsp;script&nbsp;called&nbsp;&quot;configure&quot;,&nbsp;then&nbsp;pycrypto&nbsp;fails&nbsp;to&nbsp;configure&nbsp;properly,&nbsp;because&nbsp;the&nbsp;line&nbsp;&quot;sh&nbsp;configure&quot;&nbsp;finds&nbsp;that&nbsp;other&nbsp;configure&nbsp;script&nbsp;rather&nbsp;than&nbsp;the&nbsp;pycrypto&nbsp;one.&nbsp;So&nbsp;could&nbsp;that&nbsp;command&nbsp;be&nbsp;changed?&nbsp;For&nbsp;example:&lt;br&gt;<br>
+&lt;br&gt;$&nbsp;git&nbsp;diff&lt;br&gt;diff&nbsp;--git&nbsp;a/setup.py&nbsp;b/setup.py&lt;br&gt;index&nbsp;5269e9d..950d352&nbsp;100644&lt;br&gt;---&nbsp;a/setup.py&lt;br&gt;+++&nbsp;b/setup.py&lt;br&gt;@@&nbsp;-308,7&nbsp;+308,7&nbsp;@@&nbsp;class&nbsp;PCTBuildConfigure(Command):&lt;br&gt;                &nbsp;os.chmod(&quot;configure&quot;,&nbsp;stat.S_IRUSR&nbsp;|&nbsp;stat.S_IWUSR&nbsp;|&lt;br&gt;<br>
+                         &nbsp;stat.S_IXUSR&nbsp;|&nbsp;stat.S_IRGRP&nbsp;|&nbsp;stat.S_IXGRP&nbsp;|&lt;br&gt;                         &nbsp;stat.S_IROTH&nbsp;|&nbsp;stat.S_IXOTH)&lt;br&gt;-           &nbsp;cmd&nbsp;=&nbsp;&quot;sh&nbsp;configure&quot;   &nbsp;#&nbsp;we&nbsp;use&nbsp;&quot;sh&quot;&nbsp;here&nbsp;so&nbsp;that&nbsp;it&#39;ll&nbsp;work&nbsp;on&nbsp;mingw32&nbsp;with&nbsp;standard&nbsp;&lt;a&nbsp;href=&quot;http://python.org&quot;&gt;python.org&lt;/a&gt;&nbsp;binaries&lt;br&gt;<br>
++           &nbsp;cmd&nbsp;=&nbsp;&quot;sh&nbsp;./configure&quot;  &nbsp;#&nbsp;we&nbsp;use&nbsp;&quot;sh&quot;&nbsp;here&nbsp;so&nbsp;that&nbsp;it&#39;ll&nbsp;work&nbsp;on&nbsp;mingw32&nbsp;with&nbsp;standard&nbsp;&lt;a&nbsp;href=&quot;http://python.org&quot;&gt;python.org&lt;/a&gt;&nbsp;binaries&lt;br&gt;            &nbsp;if&nbsp;self.verbose&nbsp;&lt;&nbsp;1:&lt;br&gt;                &nbsp;cmd&nbsp;+=&nbsp;&quot;&nbsp;-q&quot;&lt;br&gt;<br>
+            &nbsp;if&nbsp;os.system(cmd)&nbsp;!=&nbsp;0:&lt;br&gt;&lt;br&gt;&lt;/div&gt;or&nbsp;(maybe&nbsp;more&nbsp;portable):&lt;br&gt;&lt;br&gt;&lt;div&gt;$&nbsp;git&nbsp;diff&lt;br&gt;diff&nbsp;--git&nbsp;a/setup.py&nbsp;b/setup.py&lt;br&gt;index&nbsp;5269e9d..77fb2b0&nbsp;100644&lt;br&gt;---&nbsp;a/setup.py&lt;br&gt;+++&nbsp;b/setup.py&lt;br&gt;@@&nbsp;-308,7&nbsp;+308,7&nbsp;@@&nbsp;class&nbsp;PCTBuildConfigure(Command):&lt;br&gt;<br>
+                &nbsp;os.chmod(&quot;configure&quot;,&nbsp;stat.S_IRUSR&nbsp;|&nbsp;stat.S_IWUSR&nbsp;|&lt;br&gt;                         &nbsp;stat.S_IXUSR&nbsp;|&nbsp;stat.S_IRGRP&nbsp;|&nbsp;stat.S_IXGRP&nbsp;|&lt;br&gt;                         &nbsp;stat.S_IROTH&nbsp;|&nbsp;stat.S_IXOTH)&lt;br&gt;-           &nbsp;cmd&nbsp;=&nbsp;&quot;sh&nbsp;configure&quot;   &nbsp;#&nbsp;we&nbsp;use&nbsp;&quot;sh&quot;&nbsp;here&nbsp;so&nbsp;that&nbsp;it&#39;ll&nbsp;work&nbsp;on&nbsp;mingw32&nbsp;with&nbsp;standard&nbsp;&lt;a&nbsp;href=&quot;http://python.org&quot;&gt;python.org&lt;/a&gt;&nbsp;binaries&lt;br&gt;<br>
++           &nbsp;cmd&nbsp;=&nbsp;&quot;sh&nbsp;%s&quot;&nbsp;%&nbsp;(os.path.join(os.curdir,&nbsp;&#39;configure&#39;))  &nbsp;#&nbsp;we&nbsp;use&nbsp;&quot;sh&quot;&nbsp;here&nbsp;so&nbsp;that&nbsp;it&#39;ll&nbsp;work&nbsp;on&nbsp;mingw32&nbsp;w&lt;br&gt;            &nbsp;if&nbsp;self.verbose&nbsp;&lt;&nbsp;1:&lt;br&gt;                &nbsp;cmd&nbsp;+=&nbsp;&quot;&nbsp;-q&quot;&lt;br&gt;<br>
+            &nbsp;if&nbsp;os.system(cmd)&nbsp;!=&nbsp;0:&lt;br&gt;&lt;br&gt;&lt;div&gt;I&nbsp;have&nbsp;no&nbsp;experience&nbsp;with&nbsp;Windows,&nbsp;for&nbsp;example,&nbsp;so&nbsp;I&nbsp;don&#39;t&nbsp;know&nbsp;how&nbsp;portable&nbsp;this&nbsp;kind&nbsp;of&nbsp;change&nbsp;would&nbsp;be.&lt;br&gt;&lt;/div&gt;&lt;div&gt;&lt;br&gt;--&nbsp;&lt;br&gt;&lt;div&nbsp;dir=&quot;ltr&quot;&gt;John&nbsp;H.&nbsp;Palmieri&lt;br&gt;&lt;br&gt;<br>
+&lt;/div&gt;<br>
+&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;<br>
+
+</tt>