summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2015-03-11 01:03:07 -0700
committerTushar Gohad <tushar.gohad@intel.com>2015-03-11 01:06:52 -0700
commit06e68bb656ad96758f9944e125a1ecd12a117089 (patch)
tree9629f4e5e756a86fd1e9b42d9c32a2f082db68f5
parente388e3629ea96890c9135fd6c806f4545e369236 (diff)
downloadpyeclib-06e68bb656ad96758f9944e125a1ecd12a117089.tar.gz
Don't look for installed libraries under local paths (duh!)
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 9935d88..ee1f9ec 100644
--- a/setup.py
+++ b/setup.py
@@ -55,11 +55,14 @@ default_python_libdir = get_python_lib()
# and Tushar) cannot explain what is going on with
# distutils or libtool here.
#
+standard_library_paths = [('%s/usr/local/lib' % _exec_prefix),
+ '/lib', '/usr/lib', '/usr/local/lib']
+
default_library_paths = [default_python_libdir,
('%s/usr/local/lib' % _exec_prefix),
'/lib', '/usr/lib', '/usr/local/lib',
'src/c/liberasurecode-1.0.3/src/.libs']
-
+
default_include_paths = [default_python_incdir,
'/usr/local/include', '/usr/local/include/jerasure',
'/usr/include', 'src/c/pyeclib_c',
@@ -107,7 +110,7 @@ def _check_library(library, soname, library_url, mode, distribution):
if platform_str.find("Darwin") > -1:
library_suffix = ".dylib"
library_file = soname + library_suffix
- for dir in (default_library_paths):
+ for dir in (standard_library_paths):
library_file_path = dir + os.sep + library_file
if (os.path.isfile(library_file_path)):
missing = False