summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2015-03-10 23:58:15 -0700
committerTushar Gohad <tushar.gohad@intel.com>2015-03-11 00:31:36 -0700
commit9f36d189d9bdd12d5b9251cc7c2be19cb0909713 (patch)
tree939413e1a6f89e6b2d0d6ff2a1d2915e0bd1c4af
parent1fb179d3b53ed3476a75c96ff59c11c761df8f1a (diff)
downloadpyeclib-9f36d189d9bdd12d5b9251cc7c2be19cb0909713.tar.gz
test: Improve LD_LIBRARY_PATH determination for local tests
-rw-r--r--Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 18d2cb0..93b3458 100644
--- a/Makefile
+++ b/Makefile
@@ -34,11 +34,17 @@ install: build
UNITS := test/test_pyeclib_api.py test/test_pyeclib_c.py
test: build
- LD_LIBRARY_PATH=${TOPDIR}:${LD_LIBRARY_PATH} nosetests --exe --with-coverage \
- --cover-package pyeclib --cover-erase \
- --cover-html --cover-html-dir=${TOPDIR}/cover \
- $(UNITS)
- rm -f .coverage
+ $(eval SONAMES := $(shell find $(abs_top_builddir) -name '*.so'))
+ $(eval SODIRS := $(dir $(SONAMES)))
+ $(eval LD_LIBRARY_PATH := LD_LIBRARY_PATH="$(subst / ,/:,$(SODIRS))")
+ $(eval DYLD_LIBRARY_PATH := DYLD_LIBRARY_PATH="$(subst / ,/:,$(SODIRS))")
+ $(eval DYLD_FALLBACK_LIBRARY_PATH := DYLD_FALLBACK_LIBRARY_PATH="$(subst / ,/:,$(SODIRS))")
+ rm -rf cover .coverage
+ @$(LD_LIBRARY_PATH) $(DYLD_LIBRARY_PATH) $(DYLD_FALLBACK_LIBRARY_PATH) \
+ nosetests --exe --with-coverage \
+ --cover-package pyeclib --cover-erase \
+ --cover-html --cover-html-dir=${TOPDIR}/cover \
+ $(UNITS)
clean:
-rm -f pyeclib_c.so