summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2015-12-04 04:14:54 -0700
committerTushar Gohad <tushar.gohad@intel.com>2015-12-04 04:14:54 -0700
commit3aa1a13477e51f6eccaa67c95f673b4478f0cd89 (patch)
tree4f28e37c4acf6fbb1b25b8e3b146d14dd185f23b
parent25ddefa6d4847efe1a314e28c8824fe9b8837294 (diff)
downloadpyeclib-3aa1a13477e51f6eccaa67c95f673b4478f0cd89.tar.gz
Eliminate liberasurecode manual search/runtime_library_dirs
-rw-r--r--setup.py25
1 files changed, 0 insertions, 25 deletions
diff --git a/setup.py b/setup.py
index 7028813..12eb188 100644
--- a/setup.py
+++ b/setup.py
@@ -49,8 +49,6 @@ from setuptools.command.install import install as _install
platform_str = platform.platform()
platform_arch = platform.architecture()
default_python_incdir = get_python_inc()
-default_python_libdir = get_python_lib()
-default_library_paths = [default_python_libdir]
# utility routines
@@ -73,19 +71,6 @@ def _find_library(name):
return target_lib
-def _build_default_lib_search_path():
- default_library_paths.append('/usr/local/lib')
- arch64 = platform_arch[0].startswith('64')
- for prefix in ('/', '/usr', '/usr/local', _exec_prefix):
- libdir = os.path.join(prefix, 'lib')
- libdir64 = os.path.join(prefix, 'lib64')
- if arch64 and os.path.exists(libdir64):
- default_library_paths.append(libdir64)
- else:
- default_library_paths.append(libdir)
- return default_library_paths
-
-
def _read_file_as_str(name):
with open(name, "rt") as f:
s = f.readline().strip()
@@ -136,15 +121,6 @@ class build(_build):
# call 1.1.0 the only compatible version for now
notfound = False
- if found_path and notfound:
- # look harder
- _build_default_lib_search_path()
- for dir in (default_library_paths):
- liberasure_file_path = dir + os.sep + liberasure_file
- if (os.path.isfile(liberasure_file_path)):
- notfound = False
- break
-
if not notfound:
return
@@ -278,7 +254,6 @@ module = Extension('pyeclib_c',
'/usr/include',
'src/c/pyeclib_c',
'/usr/local/include'],
- runtime_library_dirs=default_library_paths,
libraries=['erasurecode'],
# The extra arguments are for debugging
# extra_compile_args=['-g', '-O0'],