summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortushar.gohad@intel.com <Tushar Gohad>2015-08-05 17:38:14 +0000
committertushar.gohad@intel.com <Tushar Gohad>2015-08-05 17:42:39 +0000
commit74eef0c035541c2d61e1bf4d4796f3dfb8929750 (patch)
treeed2e48a35156a4c9564d1ff92e7d6f2262e01af0
parent9bb3c040e4db1eb9848d307249ec0a30398c25ad (diff)
downloadpyeclib-74eef0c035541c2d61e1bf4d4796f3dfb8929750.tar.gz
Eliminate rpath handling
Forbidden by most distros
-rw-r--r--setup.py5
1 files changed, 0 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 2cca8f0..769f7c7 100644
--- a/setup.py
+++ b/setup.py
@@ -222,8 +222,6 @@ class install(_install):
opts[optname] = os.path.abspath(value)
installroot = install_lib.install_dir
-
- default_library_paths.insert(0, installroot)
_install.run(self)
# Another Mac-ism... If the libraries are installed
@@ -262,13 +260,10 @@ module = Extension('pyeclib_c',
'/usr/include',
'src/c/pyeclib_c',
'/usr/local/include'],
- library_dirs=default_library_paths,
runtime_library_dirs=default_library_paths,
libraries=['erasurecode'],
# The extra arguments are for debugging
# extra_compile_args=['-g', '-O0'],
- extra_link_args=['-Wl,-rpath,%s' %
- l for l in default_library_paths],
sources=['src/c/pyeclib_c/pyeclib_c.c'])
setup(name='PyECLib',