summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2015-03-13 00:25:53 -0700
committerTushar Gohad <tushar.gohad@intel.com>2015-03-13 01:20:21 -0700
commitaaf9137174c85a7f8da61dd18b581b9dd0f1f553 (patch)
tree8f02d547f895d18f1d215d7077936c9f2c458629
parente27cf19ad9fce6cbcb2287cc013592bb90525af4 (diff)
downloadpyeclib-aaf9137174c85a7f8da61dd18b581b9dd0f1f553.tar.gz
Emphasize the 'ldconfig' step in README
-rw-r--r--README4
-rw-r--r--setup.py24
2 files changed, 16 insertions, 12 deletions
diff --git a/README b/README
index 5824690..c9b220b 100644
--- a/README
+++ b/README
@@ -169,9 +169,9 @@ Quick Start
/etc/ld.so.conf
- and then run::
+ and then make sure to run::
- $ ldconfig
+ $ sudo ldconfig
References
diff --git a/setup.py b/setup.py
index 362e124..e062257 100644
--- a/setup.py
+++ b/setup.py
@@ -72,16 +72,20 @@ class build(_build):
break
if missing:
print("***************************************************")
- print("** ")
- print("** Can not locate the liberasurecode library: ")
+ print("** ")
+ print("** Can not locate the liberasurecode library: ")
print("** %s" % (liberasure_file))
- print("** ")
- print("** PyECLib requires that the liberasurecode ")
- print("** library be installed. The liberasurecode ")
- print("** library can be obtained from: ")
- print("** https://bitbucket.org/tsg-/liberasurecode.git")
- print("** ")
- print("** Please install liberasurecode and try again.")
+ print("** ")
+ print("** PyECLib requires that the liberasurecode ")
+ print("** library be installed. ")
+ print("** ")
+ print("** Please retry after installing liberasurecode: ")
+ print("** https://bitbucket.org/tsg-/liberasurecode.git ")
+ print("** ")
+ print("** If you have liberasurecode already installed, ")
+ print("** you may need to run 'sudo ldconfig' to update ")
+ print("** the loader cache. ")
+ print("** ")
print("***************************************************")
sys.exit(1)
@@ -144,7 +148,7 @@ class install(_install):
print("** Any user using this library must update: ")
print("** %s" % ldpath_str)
print("** ")
- print("** The best way to do this is to put this line: ")
+ print("** Run 'ldconfig' or place this line: ")
print("** export %s=%s" % (ldpath_str, "%susr/local/lib"
% installroot))
print("** ")