summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Greenan <kmg@box.com>2015-07-12 10:02:52 -0700
committerKevin Greenan <kmg@box.com>2015-07-12 10:02:52 -0700
commit43868eaa34de93e03d849f521c21c84f3aa17b23 (patch)
tree139c243457fd86f0fea4c5c193198cc60dfb2992
parent0acbcd251339a6dfb1fdfe3a3f2ad1ce1df67406 (diff)
downloadpyeclib-43868eaa34de93e03d849f521c21c84f3aa17b23.tar.gz
Specify correct installroot in setup.py
This was testing on both Mac OS X and Linux.
-rw-r--r--setup.py18
1 files changed, 4 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 606a15e..a843758 100644
--- a/setup.py
+++ b/setup.py
@@ -118,19 +118,9 @@ class install(_install):
prefix = opts['exec_prefix']
root = opts['root']
- # prefer root for installdir
- if root is not None:
- installroot = root
- elif prefix is not None:
- installroot = prefix
- else:
- installroot = "/"
-
- # exception is "/usr"
- if installroot.startswith("/usr"):
- installroot = "/"
+ installroot = install_lib.install_dir
- default_library_paths.insert(0, "%s/usr/local/lib" % installroot)
+ default_library_paths.insert(0, installroot)
_install.run(self)
# Another Mac-ism... If the libraries are installed
@@ -143,13 +133,13 @@ class install(_install):
print("***************************************************")
print("** ")
print("** PyECLib libraries have been installed to: ")
- print("** %susr/local/lib" % installroot)
+ print("** %s" % installroot)
print("** ")
print("** Any user using this library must update: ")
print("** %s" % ldpath_str)
print("** ")
print("** Run 'ldconfig' or place this line: ")
- print("** export %s=%s" % (ldpath_str, "%s/usr/local/lib"
+ print("** export %s=%s" % (ldpath_str, "%s"
% installroot))
print("** ")
print("** into .bashrc, .profile, or the appropriate shell")