summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-07-27 00:53:31 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-07-27 00:56:57 -0700
commitf81a59b59248f96ba2e1b5ab09fdce4cebcf67d9 (patch)
treedbc4b528b4c9616300941e2c45644ea46facfbeb
parent5d004577e27c00703ab0c95c89f44510319cd836 (diff)
downloadpyeclib-f81a59b59248f96ba2e1b5ab09fdce4cebcf67d9.tar.gz
Fix backend names to match liberasurecode ++
Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
-rw-r--r--README2
-rw-r--r--setup.py4
-rw-r--r--src/c/pyeclib_c/pyeclib_c.h22
3 files changed, 5 insertions, 23 deletions
diff --git a/README b/README
index b804026..4d12de0 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-This is v0.10 of PyECLib. This library provides a simple Python interface for
+This is v0.9.10 of PyECLib. This library provides a simple Python interface for
implementing erasure codes and is known to work with Python v2.6, 2.7 and 3.x.
To obtain the best possible performance, the library utilizes liberasurecode,
diff --git a/setup.py b/setup.py
index 02cf5df..573f4be 100644
--- a/setup.py
+++ b/setup.py
@@ -79,7 +79,7 @@ class build(_build):
print("** PyECLib requires that the liberasurecode ")
print("** library be installed. The liberasurecode ")
print("** library can be obtained from: ")
- print("** git@bitbucket.org:elambert/liberasurecode.git")
+ print("** git@bitbucket.org:tsg-/liberasurecode.git")
print("** ")
print("** Please install liberasurecode and try again.")
print("***************************************************")
@@ -187,7 +187,7 @@ module = Extension('pyeclib_c',
sources=['src/c/pyeclib_c/pyeclib_c.c'])
setup(name='PyECLib',
- version='0.10.0',
+ version='0.9.10',
author='Kevin Greenan',
author_email='kmgreen2@gmail.com',
maintainer='Kevin Greenan and Tushar Gohad',
diff --git a/src/c/pyeclib_c/pyeclib_c.h b/src/c/pyeclib_c/pyeclib_c.h
index 75b35aa..f7d8439 100644
--- a/src/c/pyeclib_c/pyeclib_c.h
+++ b/src/c/pyeclib_c/pyeclib_c.h
@@ -48,8 +48,8 @@ typedef enum {
const char *pyeclib_type_str[] = {
"not_found",
- "rs_vand",
- "rs_cauchy_orig",
+ "jerasure_rs_vand",
+ "jerasure_rs_cauchy_orig",
"flat_xor_3",
"flat_xor_4",
};
@@ -129,28 +129,10 @@ unsigned int get_best_w_for_ecc_type(pyeclib_type_t type)
#define PYECC_FLAGS_MASK 0x1
#define PYECC_FLAGS_READ_VERIFY 0x1
#define PYECC_HANDLE_NAME "pyeclib_handle"
-#define PYECC_HEADER_MAGIC 0xb0c5ecc
#define PYECC_CAUCHY_PACKETSIZE (sizeof(long) * 128)
#define PYCC_MAX_SIG_LEN 8
-/*
- * Prevent the compiler from padding
- * this by using the __packed__ keyword
- */
-typedef struct __attribute__((__packed__)) fragment_header_s
-{
- uint32_t magic;
- uint32_t idx;
- uint32_t size;
- uint32_t orig_data_size;
- // FIXME - reserve 16-bytes for md5
- uint32_t chksum;
- // We must be aligned to 16-byte boundaries
- // So, size this array accordingly
- uint32_t aligned_padding[3];
-} fragment_header_t;
-
typedef struct fragment_metadata_s
{
int size;