summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py21
1 files changed, 11 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 7f1ca9d..c62400f 100644
--- a/setup.py
+++ b/setup.py
@@ -97,17 +97,10 @@ class build(_build):
if missing:
print("***************************************************")
print("** ")
- print("** Can not locate the liberasurecode library: ")
- print("** %s" % (liberasure_file))
+ print("** Can not locate %s" % (liberasure_file))
print("** ")
- print("** PyECLib requires that the liberasurecode ")
- print("** library be installed. ")
- print("** ")
- print("** Trying to install using the bundled tarball. If ")
- print("** this fails, please retry after installing ")
- print("** liberasurecode from: ")
- print("** ")
- print("** https://bitbucket.org/tsg-/liberasurecode.git ")
+ print("** PyECLib requires liberasurecode. Trying to ")
+ print("** install using bundled tarball. ")
print("** ")
print("** If you have liberasurecode already installed, ")
print("** you may need to run 'sudo ldconfig' to update ")
@@ -131,17 +124,25 @@ class build(_build):
print(configure_cmd)
retval = os.system(configure_cmd)
if retval != 0:
+ print("**********************************************")
+ print("** ")
print("*** Error: " + library + " build failed! ")
print("*** Please install " + library + " manually. ")
print("*** project url: %s" % library_url)
+ print("** ")
+ print("**********************************************")
os.chdir(curdir)
sys.exit(retval)
make_cmd = ("make && make install")
retval = os.system(make_cmd)
if retval != 0:
+ print("**********************************************")
+ print("** ")
print("*** Error: " + library + " install failed! ")
print("*** Please install " + library + " manually. ")
print("*** project url: %s" % library_url)
+ print("** ")
+ print("**********************************************")
os.chdir(curdir)
sys.exit(retval)
os.chdir(curdir)