summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 18 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index cf7e40b..ff5b9fd 100644
--- a/setup.py
+++ b/setup.py
@@ -104,7 +104,7 @@ class build(_build):
def check_liberasure(self):
library_basename = "liberasurecode"
library_version = "1"
- library_url = "https://github.com/openstack/liberasurecode"
+ library_url = "https://opendev.org/openstack/liberasurecode"
found_path = _find_library("erasurecode")
if found_path:
@@ -230,12 +230,27 @@ setup(name='pyeclib',
author_email='kmgreen2@gmail.com',
maintainer='Kevin Greenan and Tushar Gohad',
maintainer_email='kmgreen2@gmail.com, tusharsg@gmail.com',
- url='http://git.openstack.org/cgit/openstack/pyeclib/',
- bugtrack_url='https://bugs.launchpad.net/pyeclib',
+ url='https://opendev.org/openstack/pyeclib',
+ project_urls={
+ 'Bug Tracker': 'https://bugs.launchpad.net/pyeclib',
+ },
description=('This library provides a simple Python interface for '
'implementing erasure codes. To obtain the best possible '
'performance, the underlying erasure code algorithms are '
'written in C.'),
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ ],
long_description=open('README.rst', 'r').read(),
platforms='Linux',
license='BSD',