summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-01-13 20:39:48 -0500
committerIan Cordasco <graffatcolmingov@gmail.com>2017-01-14 06:23:23 -0600
commitf13b1e4c6473f0e91135765452956055e5091fb7 (patch)
tree3ca2dfd133a60c9a3359b6235444982b6a79644f
parentdae4fa70d8d5fd98e81ceb72c007c0c60725dfec (diff)
downloadpyflakes-f13b1e4c6473f0e91135765452956055e5091fb7.tar.gz
Just pip install setuptools on AppVeyor
Use the get-pip script to bootstrap pip and setuptools to pinned versions for Python 3.2 compatibility. PyPy3's latest Windows version only supports Python 3.2, so while Python 3.2 is EOL upstream, we're still testing against it and need to be able to install our tooling (including pip and setuptools).
-rw-r--r--.appveyor.yml12
1 files changed, 5 insertions, 7 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 149be37..4011606 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -30,13 +30,11 @@ install:
# pypy3-2.4.0 and pypy-2.6.1 are manually bootstrapped and tested
- ps: (New-Object Net.WebClient).DownloadFile('https://bootstrap.pypa.io/get-pip.py', "$env:appveyor_build_folder\get-pip.py")
- - git clone https://github.com/pypa/setuptools/
- - cd setuptools
- - C:\pypy3-2.4.0-win32\pypy3 bootstrap.py
- - C:\pypy3-2.4.0-win32\pypy3 setup.py install
- - C:\pypy-2.6.1-win32\pypy bootstrap.py
- - C:\pypy-2.6.1-win32\pypy setup.py install
- - cd ..
+ # errors are ignored due to https://github.com/pypa/pip/issues/2669#issuecomment-136405390
+ # NOTE: If and when a new version of PyPy3 is released for Windows that
+ # supports anything newer than Python 3.2, remove the setuptools pin.
+ - ps: C:\pypy3-2.4.0-win32\pypy3 "$env:appveyor_build_folder\get-pip.py"; C:\pypy3-2.4.0-win32\pypy3 -m pip install -U --force-reinstall pip==8.1.2 "setuptools<30"; echo "ignore error"
+ - ps: C:\pypy-2.6.1-win32\pypy "$env:appveyor_build_folder\get-pip.py"
build: off