summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Myint <git@stevenmyint.com>2015-08-14 04:39:04 -0700
committerSteven Myint <git@stevenmyint.com>2015-08-14 05:13:09 -0700
commit5f6aa0bfee9fae4b65a8d2d2657c7f54bdd2c2d6 (patch)
tree76d9683c582fee8a4c9f578d0295e5fd7e5acf29
parent39fe2a5a19111f24f4b4af0aa431773340a7e1fb (diff)
downloadpyflakes-5f6aa0bfee9fae4b65a8d2d2657c7f54bdd2c2d6.tar.gz
Avoid running flake8 under nightly
PyPI's pep8 is not compatible with Python 3.5 yet.
-rw-r--r--.travis.yml4
1 files changed, 2 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 6070070..b63d13d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -11,10 +11,10 @@ install:
- pip install flake8==2.1.0 pep8==1.5.6
- python setup.py install
- pip list
- - flake8 --version
+ - if [ "$TRAVIS_PYTHON_VERSION" != "nightly" ]; then flake8 --version; fi
script:
- python setup.py test -q
- - flake8 pyflakes setup.py
+ - if [ "$TRAVIS_PYTHON_VERSION" != "nightly" ]; then flake8 pyflakes setup.py; fi
matrix:
allow_failures:
- python: pypy