summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorent Xicluna <florent.xicluna@gmail.com>2014-04-26 10:28:42 +0200
committerFlorent Xicluna <florent.xicluna@gmail.com>2014-04-26 10:28:42 +0200
commitf548b4420af00293af16230b1b31f5479aed3915 (patch)
treed7191d1180e97200974685cb22ffe823e8f6d78c
parentd9f42ad90e0e869b350eccdea43670597a28a7ad (diff)
downloadpyflakes-f548b4420af00293af16230b1b31f5479aed3915.tar.gz
Replace pyflakes with flake8 in the testsuite, and add configuration to tox.ini
-rw-r--r--.travis.yml5
-rw-r--r--pyflakes/__init__.py2
-rw-r--r--pyflakes/test/test_imports.py5
-rw-r--r--tox.ini9
4 files changed, 16 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index c8faa0f..88b2a1c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,10 +6,13 @@ python:
- 3.3
- pypy
install:
+ - pip install flake8
- python setup.py install
+ - pip list
+ - flake8 --version
script:
- python setup.py test -q
- - pyflakes pyflakes setup.py
+ - flake8 pyflakes setup.py
matrix:
allow_failures:
- python: pypy
diff --git a/pyflakes/__init__.py b/pyflakes/__init__.py
index 43619bf..cb2b136 100644
--- a/pyflakes/__init__.py
+++ b/pyflakes/__init__.py
@@ -1,2 +1,2 @@
-__version__ = '0.8.1'
+__version__ = '0.8.2a0'
diff --git a/pyflakes/test/test_imports.py b/pyflakes/test/test_imports.py
index 8895856..56149b5 100644
--- a/pyflakes/test/test_imports.py
+++ b/pyflakes/test/test_imports.py
@@ -184,8 +184,9 @@ class Test(TestCase):
def baz():
def fu():
pass
- ''', m.RedefinedWhileUnused, m.RedefinedWhileUnused,
- m.UnusedImport, m.UnusedImport)
+ ''',
+ m.RedefinedWhileUnused, m.RedefinedWhileUnused,
+ m.UnusedImport, m.UnusedImport)
def test_redefinedButUsedLater(self):
"""
diff --git a/tox.ini b/tox.ini
index c79e20d..e81f21d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -7,5 +7,12 @@ envlist =
[testenv]
deps =
commands =
+ pip install flake8
+ flake8 --version
python setup.py test -q
- pyflakes pyflakes setup.py
+ flake8 pyflakes setup.py
+
+[flake8]
+select = E,F,W
+builtins = unicode
+max_line_length = 89