summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörn Heissler <joernheissler@users.noreply.github.com>2018-12-22 16:57:41 +0100
committerIan Stapleton Cordasco <graffatcolmingov@gmail.com>2018-12-22 09:57:41 -0600
commitc6cc4b625b41683db8ff5287947c64744e8bae2b (patch)
tree39a0852c6d4d72952d887a1d81aa51e59e9cc27c
parent7c74ab0ddccb60a9154c2af5aa4ee4581ccada4a (diff)
downloadpyflakes-c6cc4b625b41683db8ff5287947c64744e8bae2b.tar.gz
Test with py3.7; Travis should use Xenial for 3.7 and nightly. (#379)
-rw-r--r--.travis.yml23
-rw-r--r--tox.ini2
2 files changed, 14 insertions, 11 deletions
diff --git a/.travis.yml b/.travis.yml
index 29f1d44..2113aec 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,18 +1,21 @@
language: python
cache: pip
-python:
- - 2.7
- - 3.4
- - 3.5
- - 3.6
- - nightly
- - pypy
- - pypy-5.3
- - pypy3
+matrix:
+ include:
+ - python: 2.7
+ - python: 3.4
+ - python: 3.5
+ - python: 3.6
+ - python: pypy
+ - python: pypy-5.3
+ - python: pypy3
+ - python: 3.7
+ dist: xenial
+ - python: nightly
+ dist: xenial
install:
- pip install --upgrade .
- pip list
script:
- python setup.py test -q
- if [ "$TRAVIS_PYTHON_VERSION" != "nightly" ]; then pip install flake8==2.1.0 pep8==1.5.6 && flake8 --version && flake8 pyflakes setup.py; fi
-sudo: false
diff --git a/tox.ini b/tox.ini
index fabad9d..f3db2bb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
skip_missing_interpreters = True
envlist =
- py27,py34,py35,py36,pypy,pypy3
+ py27,py34,py35,py36,py37,pypy,pypy3
[testenv]
deps =