summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml23
1 files changed, 13 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index 29f1d44..2113aec 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,18 +1,21 @@
language: python
cache: pip
-python:
- - 2.7
- - 3.4
- - 3.5
- - 3.6
- - nightly
- - pypy
- - pypy-5.3
- - pypy3
+matrix:
+ include:
+ - python: 2.7
+ - python: 3.4
+ - python: 3.5
+ - python: 3.6
+ - python: pypy
+ - python: pypy-5.3
+ - python: pypy3
+ - python: 3.7
+ dist: xenial
+ - python: nightly
+ dist: xenial
install:
- pip install --upgrade .
- pip list
script:
- python setup.py test -q
- if [ "$TRAVIS_PYTHON_VERSION" != "nightly" ]; then pip install flake8==2.1.0 pep8==1.5.6 && flake8 --version && flake8 pyflakes setup.py; fi
-sudo: false