summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2019-11-24 08:29:57 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2019-11-24 08:37:45 -0800
commit43f12de5862568f9d381e22b83b8f81173725759 (patch)
tree5a52b7e2bcab51d045b316d0a0426ea134ca7f77
parent3c43bd4a5b29330ca8d98a53c48df687342d864a (diff)
downloadpygments-git-43f12de5862568f9d381e22b83b8f81173725759.tar.gz
Document and test all supported Python versions
Document support for Python 3.8 (released October 14th, 2019) and PyPy and add them to the test matrix.
-rw-r--r--.github/workflows/build.yaml2
-rwxr-xr-xsetup.py3
-rw-r--r--tox.ini2
3 files changed, 5 insertions, 2 deletions
diff --git a/.github/workflows/build.yaml b/.github/workflows/build.yaml
index 0e8b57a3..1c979038 100644
--- a/.github/workflows/build.yaml
+++ b/.github/workflows/build.yaml
@@ -9,7 +9,7 @@ jobs:
strategy:
max-parallel: 4
matrix:
- python-version: [2.7, 3.5, 3.6, 3.7]
+ python-version: [2.7, 3.5, 3.6, 3.7, 3.8, pypy2, pypy3]
steps:
- uses: actions/checkout@v1
diff --git a/setup.py b/setup.py
index e3d43fc0..62f810d3 100755
--- a/setup.py
+++ b/setup.py
@@ -75,6 +75,9 @@ setup(
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Operating System :: OS Independent',
'Topic :: Text Processing :: Filters',
'Topic :: Utilities',
diff --git a/tox.ini b/tox.ini
index 98aedc1a..b7c91e7d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27, py36, py37
+envlist = py27, py35, py36, py37, py38, pypy, pypy3
[testenv]
deps =