summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthäus G. Chajdas <Anteru@users.noreply.github.com>2019-11-24 17:44:29 +0100
committerGitHub <noreply@github.com>2019-11-24 17:44:29 +0100
commitf9eb5d8dda366e22684019a696272db475d4c3d0 (patch)
treeca5f146207702f65be596629102ab37ec1d8fca8
parentc6dc5c16ad3f8b001889778519be57bb2fe7ea81 (diff)
parent43f12de5862568f9d381e22b83b8f81173725759 (diff)
downloadpygments-git-f9eb5d8dda366e22684019a696272db475d4c3d0.tar.gz
Merge pull request #1265 from jdufresne/pythons
Document and test all supported Python versions
-rw-r--r--.github/workflows/build.yaml2
-rwxr-xr-xsetup.py3
-rw-r--r--tox.ini2
3 files changed, 5 insertions, 2 deletions
diff --git a/.github/workflows/build.yaml b/.github/workflows/build.yaml
index 8a369376..491ef47a 100644
--- a/.github/workflows/build.yaml
+++ b/.github/workflows/build.yaml
@@ -9,7 +9,7 @@ jobs:
strategy:
max-parallel: 4
matrix:
- python-version: [2.7, 3.5, 3.6, 3.7]
+ python-version: [2.7, 3.5, 3.6, 3.7, 3.8, pypy2, pypy3]
steps:
- uses: actions/checkout@v1
diff --git a/setup.py b/setup.py
index e3d43fc0..62f810d3 100755
--- a/setup.py
+++ b/setup.py
@@ -75,6 +75,9 @@ setup(
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Operating System :: OS Independent',
'Topic :: Text Processing :: Filters',
'Topic :: Utilities',
diff --git a/tox.ini b/tox.ini
index 98aedc1a..b7c91e7d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27, py36, py37
+envlist = py27, py35, py36, py37, py38, pypy, pypy3
[testenv]
deps =