summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2018-11-25 08:37:32 +0100
committerGeorg Brandl <georg@python.org>2018-11-25 08:37:32 +0100
commit6866f8b98f4051603b560e6f6313b74eee7a12a9 (patch)
treeb9fede197239933d0b9bc6fda0030c70d281eb03
parent67ca36ddb9b8b00c9158db00fcb3e10bd6e78c58 (diff)
downloadpygments-6866f8b98f4051603b560e6f6313b74eee7a12a9.tar.gz
Minimal fixup changes for the release, add release date.2.3.0
-rw-r--r--.hgignore1
-rw-r--r--CHANGES12
-rw-r--r--Makefile6
-rw-r--r--bitbucket-pipelines.yml2
-rw-r--r--pygments/lexers/_mapping.py2
-rw-r--r--pygments/lexers/graphics.py2
-rw-r--r--pygments/lexers/javascript.py6
-rw-r--r--pygments/lexers/lisp.py5
-rw-r--r--pygments/lexers/webmisc.py3
-rw-r--r--scripts/release-checklist32
10 files changed, 45 insertions, 26 deletions
diff --git a/.hgignore b/.hgignore
index 850baf13..b564df83 100644
--- a/.hgignore
+++ b/.hgignore
@@ -8,6 +8,7 @@ syntax: glob
.project
.tags
.tox
+.cache/
Pygments.egg-info/*
TAGS
build/*
diff --git a/CHANGES b/CHANGES
index dc078635..c82ca1cf 100644
--- a/CHANGES
+++ b/CHANGES
@@ -8,22 +8,28 @@ pull request numbers to the requests at
Version 2.3.0
-------------
-(not yet released)
+(released Nov 25, 2018)
- Added lexers:
* Fennel (PR#783)
* HLSL (PR#675)
-- Added Python 3.7 support (PR#772)
+- Updated lexers:
+
+ * Dockerfile (PR#714)
+
+- Minimum Python versions changed to 2.7 and 3.5
+- Added support for Python 3.7 generator changes (PR#772)
- Fix incorrect token type in SCSS for single-quote strings (#1322)
- Use `terminal256` formatter if `TERM` contains `256` (PR#666)
- Fix incorrect handling of GitHub style fences in Markdown (PR#741, #1389)
- Fix `%a` not being highlighted in Python3 strings (PR#727)
+
Version 2.2.0
-------------
-(release Jan 22, 2017)
+(released Jan 22, 2017)
- Added lexers:
diff --git a/Makefile b/Makefile
index 82c4a124..878b94b7 100644
--- a/Makefile
+++ b/Makefile
@@ -63,3 +63,9 @@ tox-test:
tox-test-coverage:
@tox -- --with-coverage --cover-package=pygments --cover-erase $(TEST)
+
+RLMODULES = pygments.lexers
+
+regexlint:
+ @if [ -z "$(REGEXLINT)" ]; then echo "Please set REGEXLINT=checkout path"; exit 1; fi
+ PYTHONPATH=`pwd`:$(REGEXLINT) $(REGEXLINT)/regexlint/cmdline.py $(RLMODULES)
diff --git a/bitbucket-pipelines.yml b/bitbucket-pipelines.yml
index e3c74d6e..fc745f0f 100644
--- a/bitbucket-pipelines.yml
+++ b/bitbucket-pipelines.yml
@@ -31,4 +31,4 @@ pipelines:
- pip
script:
- pip install -r requirements.txt
- - tox -e py37 \ No newline at end of file
+ - tox -e py37
diff --git a/pygments/lexers/_mapping.py b/pygments/lexers/_mapping.py
index f9513e28..9ccc7615 100644
--- a/pygments/lexers/_mapping.py
+++ b/pygments/lexers/_mapping.py
@@ -153,7 +153,7 @@ LEXERS = {
'FancyLexer': ('pygments.lexers.ruby', 'Fancy', ('fancy', 'fy'), ('*.fy', '*.fancypack'), ('text/x-fancysrc',)),
'FantomLexer': ('pygments.lexers.fantom', 'Fantom', ('fan',), ('*.fan',), ('application/x-fantom',)),
'FelixLexer': ('pygments.lexers.felix', 'Felix', ('felix', 'flx'), ('*.flx', '*.flxh'), ('text/x-felix',)),
- 'FennelLexer': ('pygments.lexers.lisp', 'Fennel', (), ('*.fnl',), ()),
+ 'FennelLexer': ('pygments.lexers.lisp', 'Fennel', ('fennel', 'fnl'), ('*.fnl',), ()),
'FishShellLexer': ('pygments.lexers.shell', 'Fish', ('fish', 'fishshell'), ('*.fish', '*.load'), ('application/x-fish',)),
'FlatlineLexer': ('pygments.lexers.dsls', 'Flatline', ('flatline',), (), ('text/x-flatline',)),
'ForthLexer': ('pygments.lexers.forth', 'Forth', ('forth',), ('*.frt', '*.fs'), ('application/x-forth',)),
diff --git a/pygments/lexers/graphics.py b/pygments/lexers/graphics.py
index 5c3ed7ee..fa5aa372 100644
--- a/pygments/lexers/graphics.py
+++ b/pygments/lexers/graphics.py
@@ -79,7 +79,7 @@ class HLSLShaderLexer(RegexLexer):
"""
HLSL (Microsoft Direct3D Shader) lexer.
- .. versionadded:: 2.2
+ .. versionadded:: 2.3
"""
name = 'HLSL'
aliases = ['hlsl']
diff --git a/pygments/lexers/javascript.py b/pygments/lexers/javascript.py
index 862535c9..663557ab 100644
--- a/pygments/lexers/javascript.py
+++ b/pygments/lexers/javascript.py
@@ -1500,8 +1500,10 @@ class JuttleLexer(RegexLexer):
(r'^(?=\s|/)', Text, 'slashstartsregex'),
include('commentsandwhitespace'),
(r':\d{2}:\d{2}:\d{2}(\.\d*)?:', String.Moment),
- (r':(now|beginning|end|forever|yesterday|today|tomorrow|(\d+(\.\d*)?|\.\d+)(ms|[smhdwMy])?):', String.Moment),
- (r':\d{4}-\d{2}-\d{2}(T\d{2}:\d{2}:\d{2}(\.\d*)?)?(Z|[+-]\d{2}:\d{2}|[+-]\d{4})?:', String.Moment),
+ (r':(now|beginning|end|forever|yesterday|today|tomorrow|'
+ r'(\d+(\.\d*)?|\.\d+)(ms|[smhdwMy])?):', String.Moment),
+ (r':\d{4}-\d{2}-\d{2}(T\d{2}:\d{2}:\d{2}(\.\d*)?)?'
+ r'(Z|[+-]\d{2}:\d{2}|[+-]\d{4})?:', String.Moment),
(r':((\d+(\.\d*)?|\.\d+)[ ]+)?(millisecond|second|minute|hour|day|week|month|year)[s]?'
r'(([ ]+and[ ]+(\d+[ ]+)?(millisecond|second|minute|hour|day|week|month|year)[s]?)'
r'|[ ]+(ago|from[ ]+now))*:', String.Moment),
diff --git a/pygments/lexers/lisp.py b/pygments/lexers/lisp.py
index f1494b13..4a1ce137 100644
--- a/pygments/lexers/lisp.py
+++ b/pygments/lexers/lisp.py
@@ -2620,11 +2620,14 @@ class XtlangLexer(RegexLexer):
],
}
+
class FennelLexer(RegexLexer):
- """A lexer for the Fennel programming language <https://fennel-lang.org>
+ """A lexer for the `Fennel programming language <https://fennel-lang.org>`_.
Fennel compiles to Lua, so all the Lua builtins are recognized as well
as the special forms that are particular to the Fennel compiler.
+
+ .. versionadded:: 2.3
"""
name = 'Fennel'
aliases = ['fennel', 'fnl']
diff --git a/pygments/lexers/webmisc.py b/pygments/lexers/webmisc.py
index 712c8246..30dd3717 100644
--- a/pygments/lexers/webmisc.py
+++ b/pygments/lexers/webmisc.py
@@ -661,7 +661,8 @@ class XQueryLexer(ExtendedRegexLexer):
# NAMESPACE KEYWORD
(r'(declare)(\s+)(default)(\s+)(element|function)',
- bygroups(Keyword.Declaration, Text, Keyword.Declaration, Text, Keyword.Declaration), 'namespacekeyword'),
+ bygroups(Keyword.Declaration, Text, Keyword.Declaration, Text, Keyword.Declaration),
+ 'namespacekeyword'),
(r'(import)(\s+)(schema|module)',
bygroups(Keyword.Pseudo, Text, Keyword.Pseudo), 'namespacekeyword'),
(r'(declare)(\s+)(copy-namespaces)',
diff --git a/scripts/release-checklist b/scripts/release-checklist
index f18e6376..efc1e1e8 100644
--- a/scripts/release-checklist
+++ b/scripts/release-checklist
@@ -1,24 +1,24 @@
Release checklist
=================
-* Check hg status
-* Make check
-* Make pylint
-* Make test from clean checkout with all supported Python versions
-* Update ez_setup.py
-* Update version info in setup.py/__init__.py
+* Check ``hg status``
+* ``make check``
+* LATER when configured properly: ``make pylint``
+* ``tox``
+* Update version info in ``setup.py/__init__.py``
* Check setup.py metadata: long description, trove classifiers
-* Update release date/code name in CHANGES
-* hg commit
-* make clean
-* For every supported version:
- pythonX.Y setup.py release bdist_egg sdist upload
+* Update release date/code name in ``CHANGES``
+* ``hg commit``
+* ``make clean``
+* ``python2 setup.py release bdist_wheel``
+* ``python3 setup.py release bdist_wheel sdist``
+* ``twine upload dist/Pygments-$NEWVER*``
* Check PyPI release page for obvious errors
-* hg tag
-* Make a maintenance branch if applicable
+* ``hg tag``
+* Merge default into stable if this was a ``x.y.0``
* Update homepage (release info), regenerate docs (+printable!)
* Add new version/milestone to tracker categories
* Write announcement and send to mailing list/python-announce
-* Update version info, add new CHANGES entry for next version
-* hg commit
-* hg push
+* Update version info, add new ``CHANGES`` entry for next version
+* ``hg commit``
+* ``hg push``