summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2010-09-07 09:59:05 +0200
committerGeorg Brandl <georg@python.org>2010-09-07 09:59:05 +0200
commit717b67d975bb80ed162b0f588fa2c87bda5cb8f3 (patch)
treed030c89973d53bf9e432db453a2f059a521c93da
parent0db1c037c4417d2142b25509a8a42dd6a48f228a (diff)
downloadpygments-717b67d975bb80ed162b0f588fa2c87bda5cb8f3.tar.gz
Switch to bitbucket as main repo.
-rw-r--r--CHANGES3
-rw-r--r--docs/src/installation.txt2
-rw-r--r--docs/src/lexerdevelopment.txt4
-rw-r--r--pygments/__init__.py2
-rwxr-xr-xsetup.py2
-rw-r--r--tests/test_basic_api.py2
6 files changed, 8 insertions, 7 deletions
diff --git a/CHANGES b/CHANGES
index 3a45495b..ddbcdcfa 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,7 +1,8 @@
Pygments changelog
==================
-Issue numbers refer to the tracker at http://dev.pocoo.org/projects/pygments/.
+Issue numbers refer to the tracker at
+http://bitbucket.org/birkenfeld/pygments-main/issues.
Version 1.4
-----------
diff --git a/docs/src/installation.txt b/docs/src/installation.txt
index 22539165..17a9aad5 100644
--- a/docs/src/installation.txt
+++ b/docs/src/installation.txt
@@ -44,7 +44,7 @@ If you want to play around with the code
----------------------------------------
1. Install `Mercurial`_
-2. ``hg clone http://dev.pocoo.org/hg/pygments-main pygments``
+2. ``hg clone http://bitbucket.org/birkenfeld/pygments-main pygments``
3. ``cd pygments``
4. ``ln -s pygments /usr/lib/python2.X/site-packages``
5. ``ln -s pygmentize /usr/local/bin``
diff --git a/docs/src/lexerdevelopment.txt b/docs/src/lexerdevelopment.txt
index ea012a2b..b67d6c87 100644
--- a/docs/src/lexerdevelopment.txt
+++ b/docs/src/lexerdevelopment.txt
@@ -455,7 +455,7 @@ There are not really any simple examples for lexer callbacks, but you can see
them in action e.g. in the `compiled.py`_ source code in the `CLexer` and
`JavaLexer` classes.
-.. _compiled.py: http://dev.pocoo.org/projects/pygments/browser/pygments/lexers/compiled.py
+.. _compiled.py: http://bitbucket.org/birkenfeld/pygments-main/src/tip/pygments/lexers/compiled.py
The ExtendedRegexLexer class
@@ -513,7 +513,7 @@ For example, this is how the hypothetical lexer above would be written with the
This might sound confusing (and it can really be). But it is needed, and for an
example look at the Ruby lexer in `agile.py`_.
-.. _agile.py: http://dev.pocoo.org/projects/pygments/browser/pygments/lexers/agile.py
+.. _agile.py: https://bitbucket.org/birkenfeld/pygments-main/src/tip/pygments/lexers/agile.py
Filtering Token Streams
diff --git a/pygments/__init__.py b/pygments/__init__.py
index 97623089..93ef690f 100644
--- a/pygments/__init__.py
+++ b/pygments/__init__.py
@@ -20,7 +20,7 @@
The `Pygments tip`_ is installable with ``easy_install Pygments==dev``.
.. _Pygments tip:
- http://dev.pocoo.org/hg/pygments-main/archive/tip.tar.gz#egg=Pygments-dev
+ http://bitbucket.org/birkenfeld/pygments-main/get/tip.zip#egg=Pygments-dev
:copyright: Copyright 2006-2010 by the Pygments team, see AUTHORS.
:license: BSD, see LICENSE for details.
diff --git a/setup.py b/setup.py
index da9819c3..52bec9d9 100755
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@
The `Pygments tip`_ is installable with ``easy_install Pygments==dev``.
.. _Pygments tip:
- http://dev.pocoo.org/hg/pygments-main/archive/tip.tar.gz#egg=Pygments-dev
+ http://bitbucket.org/birkenfeld/pygments-main/get/tip.zip#egg=Pygments-dev
:copyright: Copyright 2006-2010 by the Pygments team, see AUTHORS.
:license: BSD, see LICENSE for details.
diff --git a/tests/test_basic_api.py b/tests/test_basic_api.py
index b51d9b55..d648ee51 100644
--- a/tests/test_basic_api.py
+++ b/tests/test_basic_api.py
@@ -259,7 +259,7 @@ class FiltersTest(unittest.TestCase):
self.assertEquals('BUG', tokens[1][1])
def test_codetag_boundary(self):
- # http://dev.pocoo.org/projects/pygments/ticket/368
+ # ticket #368
lx = lexers.PythonLexer()
lx.add_filter('codetagify')
text = u'# DEBUG: text'