summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgbrandl <devnull@localhost>2006-10-22 15:06:59 +0200
committergbrandl <devnull@localhost>2006-10-22 15:06:59 +0200
commit18c14bcd9a8b783fe09287379334fa0ba6975d88 (patch)
tree51aa6932b6965a76509e16f2ddba543bb66995a9
parenta18d48b33562e58953cd1a2529c3354d185b017b (diff)
downloadpygments-18c14bcd9a8b783fe09287379334fa0ba6975d88.tar.gz
[svn] Update make check.
-rw-r--r--docs/generate.py90
-rw-r--r--ez_setup.py8
-rw-r--r--pygments/__init__.py2
-rw-r--r--pygments/console.py2
-rw-r--r--pygments/formatter.py2
-rw-r--r--pygments/formatters/bbcode.py6
-rw-r--r--pygments/formatters/html.py2
-rw-r--r--pygments/formatters/latex.py2
-rw-r--r--pygments/formatters/other.py4
-rw-r--r--pygments/formatters/terminal.py2
-rw-r--r--pygments/lexer.py2
-rw-r--r--pygments/lexers/_luabuiltins.py4
-rw-r--r--pygments/lexers/_mapping.py4
-rw-r--r--pygments/lexers/_phpbuiltins.py4
-rw-r--r--pygments/lexers/agile.py2
-rw-r--r--pygments/lexers/compiled.py2
-rw-r--r--pygments/lexers/dotnet.py2
-rw-r--r--pygments/lexers/other.py2
-rw-r--r--pygments/lexers/special.py2
-rw-r--r--pygments/lexers/templates.py2
-rw-r--r--pygments/lexers/text.py2
-rw-r--r--pygments/lexers/web.py2
-rw-r--r--pygments/plugin.py4
-rw-r--r--pygments/style.py4
-rw-r--r--pygments/styles/autumn.py2
-rw-r--r--pygments/styles/borland.py2
-rw-r--r--pygments/styles/colorful.py2
-rw-r--r--pygments/styles/default.py2
-rw-r--r--pygments/styles/friendly.py2
-rw-r--r--pygments/styles/manni.py4
-rw-r--r--pygments/styles/murphy.py2
-rw-r--r--pygments/styles/native.py2
-rw-r--r--pygments/styles/pastie.py2
-rw-r--r--pygments/styles/perldoc.py2
-rw-r--r--pygments/styles/trac.py2
-rw-r--r--pygments/token.py2
-rw-r--r--pygments/util.py5
-rwxr-xr-xscripts/check_sources.py4
-rw-r--r--tests/examplefiles/smarty_example.html42
39 files changed, 117 insertions, 118 deletions
diff --git a/docs/generate.py b/docs/generate.py
index 59da281c..abdc6316 100644
--- a/docs/generate.py
+++ b/docs/generate.py
@@ -91,15 +91,15 @@ body {
}
h1 {
- font-weight: normal;
- font-size: 40px;
- color: #09839A;
+ font-weight: normal;
+ font-size: 40px;
+ color: #09839A;
}
h2 {
- font-weight: normal;
- font-size: 30px;
- color: #C73F00;
+ font-weight: normal;
+ font-size: 30px;
+ color: #C73F00;
}
h1.heading {
@@ -111,87 +111,87 @@ h2.subheading {
}
h3 {
- margin-top: 30px;
+ margin-top: 30px;
}
table.docutils {
- border-collapse: collapse;
- border: 2px solid #aaa;
- margin: 0.5em 1.5em 0.5em 1.5em;
+ border-collapse: collapse;
+ border: 2px solid #aaa;
+ margin: 0.5em 1.5em 0.5em 1.5em;
}
table.docutils td {
- padding: 2px;
- border: 1px solid #ddd;
+ padding: 2px;
+ border: 1px solid #ddd;
}
p, li, dd, dt, blockquote {
- font-size: 15px;
- color: #333;
+ font-size: 15px;
+ color: #333;
}
p {
- line-height: 150%;
- margin-bottom: 0;
- margin-top: 10px;
+ line-height: 150%;
+ margin-bottom: 0;
+ margin-top: 10px;
}
hr {
- border-top: 1px solid #ccc;
- border-bottom: 0;
- border-right: 0;
- border-left: 0;
- margin-bottom: 10px;
- margin-top: 20px;
+ border-top: 1px solid #ccc;
+ border-bottom: 0;
+ border-right: 0;
+ border-left: 0;
+ margin-bottom: 10px;
+ margin-top: 20px;
}
dl {
- margin-left: 10px;
+ margin-left: 10px;
}
li, dt {
- margin-top: 5px;
+ margin-top: 5px;
}
dt {
- font-weight: bold;
+ font-weight: bold;
}
th {
- text-align: left;
+ text-align: left;
}
a {
- color: #990000;
+ color: #990000;
}
a:hover {
- color: #c73f00;
+ color: #c73f00;
}
pre {
- background-color: #f0f0f0;
- border-top: 1px solid #ccc;
- border-bottom: 1px solid #ccc;
- padding: 5px;
- font-size: 13px;
- font-family: Bitstream Vera Sans Mono,monospace;
+ background-color: #f0f0f0;
+ border-top: 1px solid #ccc;
+ border-bottom: 1px solid #ccc;
+ padding: 5px;
+ font-size: 13px;
+ font-family: Bitstream Vera Sans Mono,monospace;
}
tt {
- font-size: 13px;
- font-family: Bitstream Vera Sans Mono,monospace;
- color: black;
- padding: 1px 2px 1px 2px;
- background-color: #f0f0f0;
+ font-size: 13px;
+ font-family: Bitstream Vera Sans Mono,monospace;
+ color: black;
+ padding: 1px 2px 1px 2px;
+ background-color: #f0f0f0;
}
cite {
- /* abusing <cite>, it's generated by ReST for `x` */
- font-size: 13px;
- font-family: Bitstream Vera Sans Mono,monospace;
- font-weight: bold;
- font-style: normal;
+ /* abusing <cite>, it's generated by ReST for `x` */
+ font-size: 13px;
+ font-family: Bitstream Vera Sans Mono,monospace;
+ font-weight: bold;
+ font-style: normal;
}
#backlink {
diff --git a/ez_setup.py b/ez_setup.py
index 548191ff..4f05955a 100644
--- a/ez_setup.py
+++ b/ez_setup.py
@@ -15,7 +15,8 @@ This file can also be run as a script to install or upgrade setuptools.
"""
import sys
DEFAULT_VERSION = "0.6c3"
-DEFAULT_URL = "http://cheeseshop.python.org/packages/%s/s/setuptools/" % sys.version[:3]
+DEFAULT_URL = "http://cheeseshop.python.org/packages/%s/s/setuptools/" % \
+ sys.version[:3]
md5_data = {
'setuptools-0.6b1-py2.3.egg': '8822caf901250d848b996b7f25c6e6ca',
@@ -214,8 +215,3 @@ if __name__=='__main__':
update_md5(sys.argv[2:])
else:
main(sys.argv[1:])
-
-
-
-
-
diff --git a/pygments/__init__.py b/pygments/__init__.py
index 23bdbccb..a0f7c2b5 100644
--- a/pygments/__init__.py
+++ b/pygments/__init__.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
Pygments
- ~~~~~~~
+ ~~~~~~~~
Pygments is a syntax highlighting package written in Python.
diff --git a/pygments/console.py b/pygments/console.py
index b7653172..6269c2f2 100644
--- a/pygments/console.py
+++ b/pygments/console.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.console
- ~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~
Format colored console output.
diff --git a/pygments/formatter.py b/pygments/formatter.py
index 168401e3..7bde9e62 100644
--- a/pygments/formatter.py
+++ b/pygments/formatter.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.formatter
- ~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~
Base formatter class.
diff --git a/pygments/formatters/bbcode.py b/pygments/formatters/bbcode.py
index 61384c7f..223d1110 100644
--- a/pygments/formatters/bbcode.py
+++ b/pygments/formatters/bbcode.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.formatters.bbcode
- ~~~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~
BBcode formatter.
@@ -22,8 +22,8 @@ class BBCodeFormatter(Formatter):
This formatter doesn't support background colors and borders, as there are
no common BBcodes for that.
-
- Some board systems (e.g. phpBB) don't support colors in their [code] tag,
+
+ Some board systems (e.g. phpBB) don't support markup in their [code] tag,
so you can't use the highlighting together with that tag.
Text in a [code] tag usually is shown with a monospace font (which this
formatter can do with the ``monofont`` option) and no spaces (which you
diff --git a/pygments/formatters/html.py b/pygments/formatters/html.py
index 6223aba6..97e49161 100644
--- a/pygments/formatters/html.py
+++ b/pygments/formatters/html.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.formatters.html
- ~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~
Formatter for HTML output.
diff --git a/pygments/formatters/latex.py b/pygments/formatters/latex.py
index 84fe5d12..52796a7e 100644
--- a/pygments/formatters/latex.py
+++ b/pygments/formatters/latex.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.formatters.latex
- ~~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~~
Formatter for LaTeX fancyvrb output.
diff --git a/pygments/formatters/other.py b/pygments/formatters/other.py
index eb8d72fc..0660f0c3 100644
--- a/pygments/formatters/other.py
+++ b/pygments/formatters/other.py
@@ -1,9 +1,9 @@
# -*- coding: utf-8 -*-
"""
pygments.formatters.other
- ~~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~~
- Other formatters.
+ Other formatters: NullFormatter, RawTokenFormatter.
:copyright: 2006 by Georg Brandl, Armin Ronacher.
:license: GNU LGPL, see LICENSE for more details.
diff --git a/pygments/formatters/terminal.py b/pygments/formatters/terminal.py
index b4b0071e..b1756c54 100644
--- a/pygments/formatters/terminal.py
+++ b/pygments/formatters/terminal.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.formatters.terminal
- ~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Formatter for terminal output with ANSI sequences.
diff --git a/pygments/lexer.py b/pygments/lexer.py
index 3d3ee865..816e99bd 100644
--- a/pygments/lexer.py
+++ b/pygments/lexer.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.lexer
- ~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~
Base lexer classes.
diff --git a/pygments/lexers/_luabuiltins.py b/pygments/lexers/_luabuiltins.py
index 69a87cfc..e6bff5df 100644
--- a/pygments/lexers/_luabuiltins.py
+++ b/pygments/lexers/_luabuiltins.py
@@ -1,13 +1,13 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers._luabuiltins
- ~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
This file contains the names and modules of lua functions
It is able to re-generate itself, but for adding new functions you
probably have to add some callbacks (see function module_callbacks).
- Do not edit the list by hand.
+ Do not edit the MODULES dict by hand.
:copyright: 2006 by Lukas Meuser.
:license: GNU LGPL, see LICENSE for more details.
diff --git a/pygments/lexers/_mapping.py b/pygments/lexers/_mapping.py
index ef80adc6..49e386f4 100644
--- a/pygments/lexers/_mapping.py
+++ b/pygments/lexers/_mapping.py
@@ -1,13 +1,13 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers._mapping
- ~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~
Lexer mapping defintions. This file is generated by itself. Everytime
you change something on a builtin lexer defintion, run this script from
the lexers folder to update it.
- Do not alter this file by hand!
+ Do not alter the LEXERS dictionary by hand.
:copyright: 2006 by Armin Ronacher, Georg Brandl.
:license: GNU LGPL, see LICENSE for more details.
diff --git a/pygments/lexers/_phpbuiltins.py b/pygments/lexers/_phpbuiltins.py
index ca6076c5..17522a8b 100644
--- a/pygments/lexers/_phpbuiltins.py
+++ b/pygments/lexers/_phpbuiltins.py
@@ -1,12 +1,12 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers._phpbuiltins
- ~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
This file loads the function names and their modules from the
php webpage and generates itself.
- Do not alter this file by hand!
+ Do not alter the MODULES dict by hand!
WARNING: the generation transfers quite much data over your
internet connection. don't run that at home, use
diff --git a/pygments/lexers/agile.py b/pygments/lexers/agile.py
index 3533c309..61292824 100644
--- a/pygments/lexers/agile.py
+++ b/pygments/lexers/agile.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers.agile
- ~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~
Lexers for agile languages: Python, Ruby, Perl.
diff --git a/pygments/lexers/compiled.py b/pygments/lexers/compiled.py
index 2655c255..576a0071 100644
--- a/pygments/lexers/compiled.py
+++ b/pygments/lexers/compiled.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers.compiled
- ~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~
Lexers for compiled languages: C/C++, Delphi, Java.
diff --git a/pygments/lexers/dotnet.py b/pygments/lexers/dotnet.py
index f7b53484..f3932c37 100644
--- a/pygments/lexers/dotnet.py
+++ b/pygments/lexers/dotnet.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers.dotnet
- ~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~
.net languages
diff --git a/pygments/lexers/other.py b/pygments/lexers/other.py
index 3c0f0b13..0cd71056 100644
--- a/pygments/lexers/other.py
+++ b/pygments/lexers/other.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers.other
- ~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~
Lexers for other languages: SQL, BrainFuck.
diff --git a/pygments/lexers/special.py b/pygments/lexers/special.py
index 9076ca51..14e21150 100644
--- a/pygments/lexers/special.py
+++ b/pygments/lexers/special.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers.special
- ~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~
Special lexers.
diff --git a/pygments/lexers/templates.py b/pygments/lexers/templates.py
index 3a735d15..b8a14008 100644
--- a/pygments/lexers/templates.py
+++ b/pygments/lexers/templates.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers.templates
- ~~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~~
Lexers for various template engines.
diff --git a/pygments/lexers/text.py b/pygments/lexers/text.py
index 3461000a..d1157fe4 100644
--- a/pygments/lexers/text.py
+++ b/pygments/lexers/text.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers.text
- ~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~
Lexers for non-source code file types: Diff, Makefiles, Ini configs etc.
diff --git a/pygments/lexers/web.py b/pygments/lexers/web.py
index 3792b885..0b90e6cd 100644
--- a/pygments/lexers/web.py
+++ b/pygments/lexers/web.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.lexers.web
- ~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~
Lexers for web-related languages: JavaScript, CSS, HTML, XML, PHP.
diff --git a/pygments/plugin.py b/pygments/plugin.py
index 7cbb9f1c..672bb6ad 100644
--- a/pygments/plugin.py
+++ b/pygments/plugin.py
@@ -27,8 +27,8 @@
yourstyle = yourstyle:YourStyle
- :coypright: 2006 by Armin Ronacher.
- :license: GNU LGPG; see LICENSE for more details.
+ :copyright: 2006 by Armin Ronacher.
+ :license: GNU LGPL, see LICENSE for more details.
"""
try:
import pkg_resources
diff --git a/pygments/style.py b/pygments/style.py
index d1c2b4eb..07ea9746 100644
--- a/pygments/style.py
+++ b/pygments/style.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.style
- ~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~
Basic style object.
@@ -17,7 +17,7 @@ class StyleMeta(type):
def __new__(mcs, name, bases, dct):
obj = type.__new__(mcs, name, bases, dct)
for token in STANDARD_TYPES:
- if not token in obj.styles:
+ if token not in obj.styles:
obj.styles[token] = ''
def colorformat(text):
diff --git a/pygments/styles/autumn.py b/pygments/styles/autumn.py
index 3fce11fd..69656433 100644
--- a/pygments/styles/autumn.py
+++ b/pygments/styles/autumn.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.autumn
- ~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~
A colorful style, inspired by the terminal highlighting style.
diff --git a/pygments/styles/borland.py b/pygments/styles/borland.py
index cc5fb6af..ac47b2de 100644
--- a/pygments/styles/borland.py
+++ b/pygments/styles/borland.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.borland
- ~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~
Style similar to the style used in the borland ides.
diff --git a/pygments/styles/colorful.py b/pygments/styles/colorful.py
index ecb983d5..c718f53e 100644
--- a/pygments/styles/colorful.py
+++ b/pygments/styles/colorful.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.colorful
- ~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~
A colorful style, inspired by CodeRay.
diff --git a/pygments/styles/default.py b/pygments/styles/default.py
index 471cf55c..9d6fd05c 100644
--- a/pygments/styles/default.py
+++ b/pygments/styles/default.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.default
- ~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~
The default highlighting style for Pygments.
diff --git a/pygments/styles/friendly.py b/pygments/styles/friendly.py
index 6a11f66f..0aee6a2c 100644
--- a/pygments/styles/friendly.py
+++ b/pygments/styles/friendly.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.friendly
- ~~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~~
A modern style based on the VIM pyte theme.
diff --git a/pygments/styles/manni.py b/pygments/styles/manni.py
index 8e485355..7805a57a 100644
--- a/pygments/styles/manni.py
+++ b/pygments/styles/manni.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.manni
- ~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~
A colorful style, inspired by the terminal highlighting style.
@@ -12,7 +12,7 @@
license but because it uses code from the pygments library it must
be LGPL compatible sooner or later. ;-)
- .. _php_port:: http://svn.fnord.name/manni/fnord.bb/lib/Highlighter/
+ .. _php port:: http://svn.fnord.name/manni/fnord.bb/lib/Highlighter/
:copyright: 2006 by Armin Ronacher, Manni <manni@fnord.name>.
:license: GNU LGPL, see LICENSE for more details.
diff --git a/pygments/styles/murphy.py b/pygments/styles/murphy.py
index c9e8dc7f..258be9ee 100644
--- a/pygments/styles/murphy.py
+++ b/pygments/styles/murphy.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.murphy
- ~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~
Murphy's style from CodeRay.
diff --git a/pygments/styles/native.py b/pygments/styles/native.py
index fa12ddad..80f2cbbf 100644
--- a/pygments/styles/native.py
+++ b/pygments/styles/native.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.native
- ~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~
pygments version of my "native" vim theme.
diff --git a/pygments/styles/pastie.py b/pygments/styles/pastie.py
index fdee664d..362e7169 100644
--- a/pygments/styles/pastie.py
+++ b/pygments/styles/pastie.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.pastie
- ~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~
Style similar to the `pastie`_ default style.
diff --git a/pygments/styles/perldoc.py b/pygments/styles/perldoc.py
index 27c9d834..f3f8985e 100644
--- a/pygments/styles/perldoc.py
+++ b/pygments/styles/perldoc.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.perldoc
- ~~~~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~~~~
Style similar to the style used in the `perldoc`_ code blocks.
diff --git a/pygments/styles/trac.py b/pygments/styles/trac.py
index 65662925..a7767f2f 100644
--- a/pygments/styles/trac.py
+++ b/pygments/styles/trac.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.styles.trac
- ~~~~~~~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~~~~~~~
Port of the default trac highlighter design.
diff --git a/pygments/token.py b/pygments/token.py
index ca542bc0..7ec93262 100644
--- a/pygments/token.py
+++ b/pygments/token.py
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
"""
pygments.token
- ~~~~~~~~~~~~~
+ ~~~~~~~~~~~~~~
Basic token types and the standard tokens.
diff --git a/pygments/util.py b/pygments/util.py
index 65261964..4a427fb8 100644
--- a/pygments/util.py
+++ b/pygments/util.py
@@ -1,9 +1,10 @@
# -*- coding: utf-8 -*-
"""
pygments.util
- ~~~~~~~~~~~~
+ ~~~~~~~~~~~~~
- Utility functions.
+ Utility functions, currently only for parsing lexer
+ and formatter options.
:copyright: 2006 by Georg Brandl.
:license: GNU LGPL, see LICENSE for more details.
diff --git a/scripts/check_sources.py b/scripts/check_sources.py
index 2c90df8b..17207d94 100755
--- a/scripts/check_sources.py
+++ b/scripts/check_sources.py
@@ -29,7 +29,9 @@ def checker(*suffixes, **kwds):
return deco
-copyright_re = re.compile(r'^ :copyright: 200\d(-200\d)? by (\w| )+(, (\w| )+)*\.$')
+name_mail_re = r'[\w ]+(<.*?>)?'
+copyright_re = re.compile(r'^ :copyright: 200\d(-200\d)? by %s(, %s)*\.$' %
+ (name_mail_re, name_mail_re))
coding_re = re.compile(r'coding[:=]\s*([-\w.]+)')
not_ix_re = re.compile(r'\bnot\s+\S+?\s+i[sn]\s\S+')
is_const_re = re.compile(r'if.*?==\s+(None|False|True)\b')
diff --git a/tests/examplefiles/smarty_example.html b/tests/examplefiles/smarty_example.html
index 2deb65df..cf4ffdc3 100644
--- a/tests/examplefiles/smarty_example.html
+++ b/tests/examplefiles/smarty_example.html
@@ -183,27 +183,27 @@
{if $footer_info}
<div class="serendipity_pageFooter">
- {if $footer_info}
- {if $footer_prev_page}
- <span class="previous"><a href="{$footer_prev_page}">&laquo; {$CONST.PREVIOUS_PAGE}</a></span>
- {else}
- <span class="previous">&#160;</span>
- {/if}
- {else}
- {/if}
-
- {if $footer_info}
- <span class="entries_info">({$footer_info})</span>
- {/if}
-
- {if $footer_info}
- {if $footer_next_page}
- <span class="next"><a href="{$footer_next_page}">{$CONST.NEXT_PAGE} &raquo;</a></span>
- {else}
- <span class="next">&#160;</span>
- {/if}
- {else}
- {/if}
+ {if $footer_info}
+ {if $footer_prev_page}
+ <span class="previous"><a href="{$footer_prev_page}">&laquo; {$CONST.PREVIOUS_PAGE}</a></span>
+ {else}
+ <span class="previous">&#160;</span>
+ {/if}
+ {else}
+ {/if}
+
+ {if $footer_info}
+ <span class="entries_info">({$footer_info})</span>
+ {/if}
+
+ {if $footer_info}
+ {if $footer_next_page}
+ <span class="next"><a href="{$footer_next_page}">{$CONST.NEXT_PAGE} &raquo;</a></span>
+ {else}
+ <span class="next">&#160;</span>
+ {/if}
+ {else}
+ {/if}
</div>{/if}
{serendipity_hookPlugin hook="entries_footer"}
<!-- ENTRIES END -->