summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnteru <bitbucket@ca.sh13.net>2018-12-17 18:26:02 +0000
committerAnteru <bitbucket@ca.sh13.net>2018-12-17 18:26:02 +0000
commit5f037acc008cc3ed40a2d17cefa3c4401a42b423 (patch)
tree728301b701f9b16056ba4266248f0ab4629e1569
parent7e9bc6d044052634927463d2edd6f77555dbf78c (diff)
parent4452f14d50f695c4cfaa2d69038dde09a9754b71 (diff)
downloadpygments-5f037acc008cc3ed40a2d17cefa3c4401a42b423.tar.gz
Merged in witchard/pygments-main (pull request #706)
Added support for text/x-shellscript mime type.
-rw-r--r--pygments/lexers/shell.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/pygments/lexers/shell.py b/pygments/lexers/shell.py
index 0fd73464..b3702e92 100644
--- a/pygments/lexers/shell.py
+++ b/pygments/lexers/shell.py
@@ -38,7 +38,7 @@ class BashLexer(RegexLexer):
'*.exheres-0', '*.exlib', '*.zsh',
'.bashrc', 'bashrc', '.bash_*', 'bash_*', 'zshrc', '.zshrc',
'PKGBUILD']
- mimetypes = ['application/x-sh', 'application/x-shellscript']
+ mimetypes = ['application/x-sh', 'application/x-shellscript', 'text/x-shellscript']
tokens = {
'root': [